aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-01-09 14:08:12 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commit184a6ac199a512beca8b6bee1c9fd42ca23879eb (patch)
treef7d4d7b19d8271b0cef4a3f0f6c5ea41a81e5bef /debian/rules
parent35281848384ca7503aab3fab95a4ec697810e1b3 (diff)
downloadscm-184a6ac199a512beca8b6bee1c9fd42ca23879eb.tar.gz
scm-184a6ac199a512beca8b6bee1c9fd42ca23879eb.zip
Import Debian changes 5e4-3debian/5e4-3
scm (5e4-3) unstable; urgency=low * debian/rules (SCM_OPTIONS): Add -F differ. * debian/control (libscm-dev): New package. We don't make a shared library because there is no standardization of SCM options, and no way to indicate in a non-brittle fashion what SCM options are available in any particular build, nor any standardization of sonames. * debian/rules (build): Build libscm.a too. (install): Install libscm.a, scm.h, scmfig.h, and scmflags.h into libscm-dev. Don't install header files in scm package. (Closes: #459828) * debian/copyright: Add proper authorship and copyright information; make mention of the special library linking exception since we are now packaging the library.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 25 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index cb58dc5..e8f5033 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,8 @@ SCM_OPTIONS = -p $(PLATFORM) \
-F dynamic-linking \
-F xlib \
-F dump \
- -F macro
+ -F macro \
+ -F differ
# -F dump
# -F turtlegr
@@ -74,9 +75,17 @@ else
endif
test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
+
+# Main SCM binary.
./build ${SCM_OPTIONS} | tee debian/bld
chmod ug+x debian/bld
debian/bld
+
+# SCM library
+ ./build -t lib $(SCM_OPTIONS) | tee debian/bld
+ chmod ug+x debian/bld
+ debian/bld
+
make scm.info
make Xlibscm.info
texi2html -monolithic scm.texi
@@ -110,6 +119,7 @@ install: build
dh_installdirs
-rm -rf debian/scm
+ -rm -rf debian/libscm-dev
# debian/scm
$(INSTALL_DIR) debian/scm
@@ -129,8 +139,8 @@ install: build
chmod +x debian/scm/usr/lib/scm/xgen.scm
# headers
- $(INSTALL_DIR) debian/scm/usr/include/scm
- $(INSTALL_DATA) *.h debian/scm/usr/include/scm
+# $(INSTALL_DIR) debian/scm/usr/include/scm
+# $(INSTALL_DATA) *.h debian/scm/usr/include/scm
# man pages
$(INSTALL_DIR) debian/scm/usr/share/man/man1
@@ -164,6 +174,18 @@ install: build
$(INSTALL_DATA) Xlibscm.info* debian/scm/usr/share/info
gzip -9 debian/scm/usr/share/info/*
+# library package
+ $(INSTALL_DIR) debian/libscm-dev/usr/lib
+ $(INSTALL_DIR) debian/libscm-dev/usr/include
+ $(INSTALL_DIR) debian/libscm-dev/usr/share/doc/libscm-dev
+ $(INSTALL_DATA) libscm.a debian/libscm-dev/usr/lib
+ $(INSTALL_DATA) scm.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmfig.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmflags.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) debian/changelog debian/libscm-dev/usr/share/doc/libscm-dev/changelog.Debian
+ $(INSTALL_DATA) ChangeLog debian/libscm-dev/usr/share/doc/libscm-dev/changelog
+ $(INSTALL_DATA) debian/copyright debian/libscm-dev/usr/share/doc/libscm-dev
+
binary-arch: build install
dh_testdir
dh_testroot