aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-01-09 14:08:12 -0500
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commit184a6ac199a512beca8b6bee1c9fd42ca23879eb (patch)
treef7d4d7b19d8271b0cef4a3f0f6c5ea41a81e5bef
parent35281848384ca7503aab3fab95a4ec697810e1b3 (diff)
downloadscm-184a6ac199a512beca8b6bee1c9fd42ca23879eb.tar.gz
scm-184a6ac199a512beca8b6bee1c9fd42ca23879eb.zip
Import Debian changes 5e4-3debian/5e4-3
scm (5e4-3) unstable; urgency=low * debian/rules (SCM_OPTIONS): Add -F differ. * debian/control (libscm-dev): New package. We don't make a shared library because there is no standardization of SCM options, and no way to indicate in a non-brittle fashion what SCM options are available in any particular build, nor any standardization of sonames. * debian/rules (build): Build libscm.a too. (install): Install libscm.a, scm.h, scmfig.h, and scmflags.h into libscm-dev. Don't install header files in scm package. (Closes: #459828) * debian/copyright: Add proper authorship and copyright information; make mention of the special library linking exception since we are now packaging the library.
-rw-r--r--debian/changelog19
-rw-r--r--debian/control10
-rw-r--r--debian/copyright45
-rw-r--r--debian/prerm7
-rwxr-xr-xdebian/rules28
5 files changed, 97 insertions, 12 deletions
diff --git a/debian/changelog b/debian/changelog
index 9b24e58..8c2525d 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,22 @@
+scm (5e4-3) unstable; urgency=low
+
+ * debian/rules (SCM_OPTIONS): Add -F differ.
+
+ * debian/control (libscm-dev): New package. We don't make a shared library
+ because there is no standardization of SCM options, and no way to indicate
+ in a non-brittle fashion what SCM options are available in any particular
+ build, nor any standardization of sonames.
+ * debian/rules (build): Build libscm.a too.
+ (install): Install libscm.a, scm.h, scmfig.h, and scmflags.h into
+ libscm-dev. Don't install header files in scm package.
+ (Closes: #459828)
+
+ * debian/copyright: Add proper authorship and copyright information; make
+ mention of the special library linking exception since we are now
+ packaging the library.
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Wed, 09 Jan 2008 14:08:12 -0500
+
scm (5e4-2) unstable; urgency=low
* Properly acknowledge NMU 5e3-6.1. (Closes: #369576, #458284).
diff --git a/debian/control b/debian/control
index cca40a5..dad9258 100644
--- a/debian/control
+++ b/debian/control
@@ -13,3 +13,13 @@ Depends: slib (>> 3a5), ${shlibs:Depends}
Description: A Scheme language interpreter
Scm conforms to Revised^5 Report on the Algorithmic Language Scheme and
the IEEE P1178 specification.
+
+Package: libscm-dev
+Architecture: alpha amd64 arm hppa i386 hurd-i386 m68k mips mipsel powerpc ppc64 sparc ia64 armel armeb
+Section: libdevel
+Priority: optional
+Depends: scm (= ${source:Version}), slib (>> 3a5), ${shlibs:Depends}
+Description: Embeddable library for SCM Scheme language interpreter
+ This is a static library which provides the functionality of SCM, making it
+ convenient add scheme functionality to other programs.
+
diff --git a/debian/copyright b/debian/copyright
index a9a786e..7f43eac 100644
--- a/debian/copyright
+++ b/debian/copyright
@@ -10,7 +10,48 @@ For more information see:
http://www-swiss.ai.mit.edu/~jaffer/SCM
+Author: Aubrey Jaffer
+Further portions written by:
+ Richard E. Harke
+ Tanel Tammet
+ William Clinger
+ Mkinen Sami
+ Jarkko Leppanen
+ The Free Software Foundation
+ Paradigm Associates Inc.
+ Digital Equipment Corp.
+ Tektronix, Inc.
+
+
+Copyright:
+ 1984-2006 by the Free Software Foundation
+ 1996, 2000-2001, 2003, 2007 by Aubrey Jaffer
+Portions Copyright:
+ 1990 by W. Wilson Ho
+ 1992-1997 by Tanel Tammet
+ 1992 by William Clinger
+ 1989 by Paradigm Associates Inc.
+ 1992 by Mkinen Sami and Jarkko Leppanen
+ 1985-1991 by Digital Equipment Corp.
+ 1990-1991 by Textronix, Inc.
+
License:
-scm is distributed under the GNU General Public License. See
-/usr/share/common-licenses/GPL for details.
+scm as a whole is distributed under the GNU General Public License.
+See /usr/share/common-licenses/GPL for details. Some individual
+source files and portions of the documentation can be distributed under
+more liberal terms as described in each file.
+
+As a special exception, the Free Software Foundation gives permission
+for additional uses of the text contained in its release of SCM.
+
+The exception is that, if you link the SCM library with other files
+to produce an executable, this does not by itself cause the
+resulting executable to be covered by the GNU General Public License.
+Your use of that executable is in no way restricted on account of
+linking the SCM library code into it.
+
+This exception does not however invalidate any other reasons why
+the executable file might be covered by the GNU General Public License.
+
+
diff --git a/debian/prerm b/debian/prerm
index 37960c3..b77bd33 100644
--- a/debian/prerm
+++ b/debian/prerm
@@ -6,13 +6,6 @@ if [ \( "$1" = "upgrade" -o "$1" = "remove" \) -a -L /usr/doc/scm ]; then
rm -f /usr/doc/scm
fi
-# doc base support
-if [ "$1" = remove -o "$1" = upgrade ]; then
- if test -x /usr/sbin/install-docs >/dev/null 2>&1; then
- /usr/sbin/install-docs -r scm
- fi
-fi
-
install-info --quiet --remove /usr/share/info/scm.info.gz
#DEBHELPER#
diff --git a/debian/rules b/debian/rules
index cb58dc5..e8f5033 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,8 @@ SCM_OPTIONS = -p $(PLATFORM) \
-F dynamic-linking \
-F xlib \
-F dump \
- -F macro
+ -F macro \
+ -F differ
# -F dump
# -F turtlegr
@@ -74,9 +75,17 @@ else
endif
test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
+
+# Main SCM binary.
./build ${SCM_OPTIONS} | tee debian/bld
chmod ug+x debian/bld
debian/bld
+
+# SCM library
+ ./build -t lib $(SCM_OPTIONS) | tee debian/bld
+ chmod ug+x debian/bld
+ debian/bld
+
make scm.info
make Xlibscm.info
texi2html -monolithic scm.texi
@@ -110,6 +119,7 @@ install: build
dh_installdirs
-rm -rf debian/scm
+ -rm -rf debian/libscm-dev
# debian/scm
$(INSTALL_DIR) debian/scm
@@ -129,8 +139,8 @@ install: build
chmod +x debian/scm/usr/lib/scm/xgen.scm
# headers
- $(INSTALL_DIR) debian/scm/usr/include/scm
- $(INSTALL_DATA) *.h debian/scm/usr/include/scm
+# $(INSTALL_DIR) debian/scm/usr/include/scm
+# $(INSTALL_DATA) *.h debian/scm/usr/include/scm
# man pages
$(INSTALL_DIR) debian/scm/usr/share/man/man1
@@ -164,6 +174,18 @@ install: build
$(INSTALL_DATA) Xlibscm.info* debian/scm/usr/share/info
gzip -9 debian/scm/usr/share/info/*
+# library package
+ $(INSTALL_DIR) debian/libscm-dev/usr/lib
+ $(INSTALL_DIR) debian/libscm-dev/usr/include
+ $(INSTALL_DIR) debian/libscm-dev/usr/share/doc/libscm-dev
+ $(INSTALL_DATA) libscm.a debian/libscm-dev/usr/lib
+ $(INSTALL_DATA) scm.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmfig.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmflags.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) debian/changelog debian/libscm-dev/usr/share/doc/libscm-dev/changelog.Debian
+ $(INSTALL_DATA) ChangeLog debian/libscm-dev/usr/share/doc/libscm-dev/changelog
+ $(INSTALL_DATA) debian/copyright debian/libscm-dev/usr/share/doc/libscm-dev
+
binary-arch: build install
dh_testdir
dh_testroot