aboutsummaryrefslogtreecommitdiffstats
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules28
1 files changed, 25 insertions, 3 deletions
diff --git a/debian/rules b/debian/rules
index cb58dc5..e8f5033 100755
--- a/debian/rules
+++ b/debian/rules
@@ -47,7 +47,8 @@ SCM_OPTIONS = -p $(PLATFORM) \
-F dynamic-linking \
-F xlib \
-F dump \
- -F macro
+ -F macro \
+ -F differ
# -F dump
# -F turtlegr
@@ -74,9 +75,17 @@ else
endif
test -e /usr/share/slib || \
(echo "Must have slib installed for compile" && exit 1)
+
+# Main SCM binary.
./build ${SCM_OPTIONS} | tee debian/bld
chmod ug+x debian/bld
debian/bld
+
+# SCM library
+ ./build -t lib $(SCM_OPTIONS) | tee debian/bld
+ chmod ug+x debian/bld
+ debian/bld
+
make scm.info
make Xlibscm.info
texi2html -monolithic scm.texi
@@ -110,6 +119,7 @@ install: build
dh_installdirs
-rm -rf debian/scm
+ -rm -rf debian/libscm-dev
# debian/scm
$(INSTALL_DIR) debian/scm
@@ -129,8 +139,8 @@ install: build
chmod +x debian/scm/usr/lib/scm/xgen.scm
# headers
- $(INSTALL_DIR) debian/scm/usr/include/scm
- $(INSTALL_DATA) *.h debian/scm/usr/include/scm
+# $(INSTALL_DIR) debian/scm/usr/include/scm
+# $(INSTALL_DATA) *.h debian/scm/usr/include/scm
# man pages
$(INSTALL_DIR) debian/scm/usr/share/man/man1
@@ -164,6 +174,18 @@ install: build
$(INSTALL_DATA) Xlibscm.info* debian/scm/usr/share/info
gzip -9 debian/scm/usr/share/info/*
+# library package
+ $(INSTALL_DIR) debian/libscm-dev/usr/lib
+ $(INSTALL_DIR) debian/libscm-dev/usr/include
+ $(INSTALL_DIR) debian/libscm-dev/usr/share/doc/libscm-dev
+ $(INSTALL_DATA) libscm.a debian/libscm-dev/usr/lib
+ $(INSTALL_DATA) scm.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmfig.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) scmflags.h debian/libscm-dev/usr/include
+ $(INSTALL_DATA) debian/changelog debian/libscm-dev/usr/share/doc/libscm-dev/changelog.Debian
+ $(INSTALL_DATA) ChangeLog debian/libscm-dev/usr/share/doc/libscm-dev/changelog
+ $(INSTALL_DATA) debian/copyright debian/libscm-dev/usr/share/doc/libscm-dev
+
binary-arch: build install
dh_testdir
dh_testroot