summaryrefslogtreecommitdiffstats
path: root/system
diff options
context:
space:
mode:
authorTzu-Jung Lee <tjlee@ambarella.com>2013-05-26 10:40:25 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-26 23:00:30 +0200
commitd67b3a54af65ab4818a891458d2d59f91f239f99 (patch)
treec2884c0d498a60f3459d19a2a4001444e572412d /system
parent8cb59e6585b6d1f87e3418418796f15dfdbdbce3 (diff)
downloadbuildroot-novena-d67b3a54af65ab4818a891458d2d59f91f239f99.tar.gz
buildroot-novena-d67b3a54af65ab4818a891458d2d59f91f239f99.zip
skeleton: add default login port to /etc/securetty
We ran into a "Login incorrect" problem when running the same rootfs image across platforms with different loging ports ttyS0/1/2/3. Simply assignning "console" to BR2_TARGET_GENERIC_GETTY_PORT, which in turn modifies the /etc/inittab, is not enough because the "console" device was missing in the /etc/securetty. While current securetty has enumerated a lot of ttys, this patch should save some efforts to enumerate more. [Peter: guard with single quotes] Signed-off-by: Tzu-Jung Lee <tjlee@ambarella.com> Signed-off-by: Spenser Gilliland <spenser@gillilanding.com> Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'system')
-rw-r--r--system/system.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/system/system.mk b/system/system.mk
index 44a33ae61..50c86ad60 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -9,6 +9,10 @@ TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
TARGET_GENERIC_GETTY_TERM:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_TERM))
+target-generic-securetty:
+ grep -q '^$(TARGET_GENERIC_GETTY)$$' $(TARGET_DIR)/etc/securetty || \
+ echo '$(TARGET_GENERIC_GETTY)' >> $(TARGET_DIR)/etc/securetty
+
target-generic-hostname:
mkdir -p $(TARGET_DIR)/etc
echo "$(TARGET_GENERIC_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
@@ -40,6 +44,10 @@ target-generic-do-remount-rw:
target-generic-dont-remount-rw:
$(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
+ifneq ($(TARGET_GENERIC_GETTY),)
+TARGETS += target-generic-securetty
+endif
+
ifneq ($(TARGET_GENERIC_HOSTNAME),)
TARGETS += target-generic-hostname
endif