summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-xsupport/scripts/graph-depends1
-rw-r--r--system/system.mk8
2 files changed, 9 insertions, 0 deletions
diff --git a/support/scripts/graph-depends b/support/scripts/graph-depends
index 180c81d94..3bab725cd 100755
--- a/support/scripts/graph-depends
+++ b/support/scripts/graph-depends
@@ -161,6 +161,7 @@ def remove_redundant_deps(deps):
return newdeps
TARGET_EXCEPTIONS = [
+ "target-generic-securetty",
"target-generic-issue",
"target-generic-getty-busybox",
"target-generic-do-remount-rw",
diff --git a/system/system.mk b/system/system.mk
index 44a33ae61..50c86ad60 100644
--- a/system/system.mk
+++ b/system/system.mk
@@ -9,6 +9,10 @@ TARGET_GENERIC_GETTY:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_PORT))
TARGET_GENERIC_GETTY_BAUDRATE:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_BAUDRATE))
TARGET_GENERIC_GETTY_TERM:=$(call qstrip,$(BR2_TARGET_GENERIC_GETTY_TERM))
+target-generic-securetty:
+ grep -q '^$(TARGET_GENERIC_GETTY)$$' $(TARGET_DIR)/etc/securetty || \
+ echo '$(TARGET_GENERIC_GETTY)' >> $(TARGET_DIR)/etc/securetty
+
target-generic-hostname:
mkdir -p $(TARGET_DIR)/etc
echo "$(TARGET_GENERIC_HOSTNAME)" > $(TARGET_DIR)/etc/hostname
@@ -40,6 +44,10 @@ target-generic-do-remount-rw:
target-generic-dont-remount-rw:
$(SED) '/^[^#].*# REMOUNT_ROOTFS_RW$$/s~^~#~' $(TARGET_DIR)/etc/inittab
+ifneq ($(TARGET_GENERIC_GETTY),)
+TARGETS += target-generic-securetty
+endif
+
ifneq ($(TARGET_GENERIC_HOSTNAME),)
TARGETS += target-generic-hostname
endif