summaryrefslogtreecommitdiffstats
path: root/package/kexec/kexec.mk
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-24 14:06:13 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-24 14:06:13 +0000
commitcb726c166d9c6d17f5232ba3aea650b5a8411ce4 (patch)
tree69b991d43f55484b6307784e5b68e00a51594814 /package/kexec/kexec.mk
parent29cc530407abd7b4ead9faba33da84d789ba94b7 (diff)
downloadbuildroot-novena-cb726c166d9c6d17f5232ba3aea650b5a8411ce4.tar.gz
buildroot-novena-cb726c166d9c6d17f5232ba3aea650b5a8411ce4.zip
Patch correctly kexec, make sure utils is built using HOSTCC
Diffstat (limited to 'package/kexec/kexec.mk')
-rw-r--r--package/kexec/kexec.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index 36f2d8cc5..c6155194f 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -35,9 +35,10 @@ $(KEXEC_DIR)/.unpacked: $(DL_DIR)/$(KEXEC_SOURCE) $(DL_DIR)/$(KEXEC_PATCH)
$(KEXEC_CAT) $(DL_DIR)/$(KEXEC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(KEXEC_PATCH),)
(cd $(KEXEC_DIR) && $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_PATCH) | patch -p1)
- toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
+ package/kexec/kexec-patch.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches 00list
+# toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
endif
- toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.dpatch
+ toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.patch
touch $@
$(KEXEC_DIR)/.configured: $(KEXEC_DIR)/.unpacked