summaryrefslogtreecommitdiffstats
path: root/package/kexec
diff options
context:
space:
mode:
authorUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-24 14:06:13 +0000
committerUlf Samuelsson <ulf.samuelsson@atmel.com>2007-07-24 14:06:13 +0000
commitcb726c166d9c6d17f5232ba3aea650b5a8411ce4 (patch)
tree69b991d43f55484b6307784e5b68e00a51594814 /package/kexec
parent29cc530407abd7b4ead9faba33da84d789ba94b7 (diff)
downloadbuildroot-novena-cb726c166d9c6d17f5232ba3aea650b5a8411ce4.tar.gz
buildroot-novena-cb726c166d9c6d17f5232ba3aea650b5a8411ce4.zip
Patch correctly kexec, make sure utils is built using HOSTCC
Diffstat (limited to 'package/kexec')
-rwxr-xr-xpackage/kexec/kexec-patch.sh16
-rw-r--r--package/kexec/kexec-tools-003-build-util-using-host-gcc.patch17
-rw-r--r--package/kexec/kexec.mk5
3 files changed, 36 insertions, 2 deletions
diff --git a/package/kexec/kexec-patch.sh b/package/kexec/kexec-patch.sh
new file mode 100755
index 000000000..4889705fc
--- /dev/null
+++ b/package/kexec/kexec-patch.sh
@@ -0,0 +1,16 @@
+#!/bin/bash
+SRCDIR=$1
+PATCHDIR=$2
+PATCHLIST=${PATCHDIR}/$3
+
+do_patch()
+{
+ cd ${SRCDIR}
+ for f in `cat ${PATCHLIST}` ; do
+ echo ${PATCHDIR}/$f
+ cat ${PATCHDIR}/$f | patch -p2
+ done
+}
+
+do_patch
+
diff --git a/package/kexec/kexec-tools-003-build-util-using-host-gcc.patch b/package/kexec/kexec-tools-003-build-util-using-host-gcc.patch
new file mode 100644
index 000000000..d2090d40f
--- /dev/null
+++ b/package/kexec/kexec-tools-003-build-util-using-host-gcc.patch
@@ -0,0 +1,17 @@
+diff -urN kexec-tools-1.101-0rig/util/Makefile kexec-tools-1.101/util/Makefile
+--- kexec-tools-1.101-0rig/util/Makefile 2004-12-16 22:08:21.000000000 +0100
++++ kexec-tools-1.101/util/Makefile 2007-07-24 16:32:48.000000000 +0200
+@@ -1,4 +1,4 @@
+ BIN_TO_HEX:= $(OBJDIR)/bin/bin-to-hex
+ $(BIN_TO_HEX): util/bin-to-hex.c
+ mkdir -p $(@D)
+- $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
++ $(HOSTCC) $(HOST_CFLAGS) $< -o $@
+diff -urN kexec-tools-1.101-0rig/util/Makefile~ kexec-tools-1.101/util/Makefile~
+--- kexec-tools-1.101-0rig/util/Makefile~ 1970-01-01 01:00:00.000000000 +0100
++++ kexec-tools-1.101/util/Makefile~ 2004-12-16 22:08:21.000000000 +0100
+@@ -0,0 +1,4 @@
++BIN_TO_HEX:= $(OBJDIR)/bin/bin-to-hex
++$(BIN_TO_HEX): util/bin-to-hex.c
++ mkdir -p $(@D)
++ $(BUILD_CC) $(BUILD_CFLAGS) $< -o $@
diff --git a/package/kexec/kexec.mk b/package/kexec/kexec.mk
index 36f2d8cc5..c6155194f 100644
--- a/package/kexec/kexec.mk
+++ b/package/kexec/kexec.mk
@@ -35,9 +35,10 @@ $(KEXEC_DIR)/.unpacked: $(DL_DIR)/$(KEXEC_SOURCE) $(DL_DIR)/$(KEXEC_PATCH)
$(KEXEC_CAT) $(DL_DIR)/$(KEXEC_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
ifneq ($(KEXEC_PATCH),)
(cd $(KEXEC_DIR) && $(KEXEC_CAT) $(DL_DIR)/$(KEXEC_PATCH) | patch -p1)
- toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
+ package/kexec/kexec-patch.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches 00list
+# toolchain/patch-kernel.sh $(KEXEC_DIR) $(KEXEC_DIR)/debian/patches \*.patch
endif
- toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.dpatch
+ toolchain/patch-kernel.sh $(KEXEC_DIR) package/kexec/ kexec\*.patch
touch $@
$(KEXEC_DIR)/.configured: $(KEXEC_DIR)/.unpacked