summaryrefslogtreecommitdiffstats
path: root/package/gnutls
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-02 04:50:10 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-02 15:52:58 +0100
commit7155fb7dd6386377eaf05b7436bc9c5dd024d0ad (patch)
treeb92d56d37a38f9d0c4ff97153a13141653c7bdba /package/gnutls
parent50e562bc4ab83128f093f44b34327f8c23782b06 (diff)
downloadbuildroot-novena-7155fb7dd6386377eaf05b7436bc9c5dd024d0ad.tar.gz
buildroot-novena-7155fb7dd6386377eaf05b7436bc9c5dd024d0ad.zip
gnutls: handle libidn properly
Add it to the dependencies when it's available. But disable crywrap when it's a nommu system since it uses fork() Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/gnutls.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 1cbcf7021..4c918c1f8 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -20,6 +20,10 @@ GNUTLS_INSTALL_STAGING = YES
# libpthread autodetection poisons the linkpath
GNUTLS_CONF_OPT += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
+# libidn support for nommu must exclude the crywrap wrapper (uses fork)
+GNUTLS_CONF_OPT += $(if $(BR2_USE_MMU),,--disable-crywrap)
+GNUTLS_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBIDN),libidn)
+
# Some examples in doc/examples use wchar
define GNUTLS_DISABLE_DOCS
$(SED) 's/ doc / /' $(@D)/Makefile.in