summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/gnutls/gnutls.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 1cbcf7021..4c918c1f8 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -20,6 +20,10 @@ GNUTLS_INSTALL_STAGING = YES
# libpthread autodetection poisons the linkpath
GNUTLS_CONF_OPT += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
+# libidn support for nommu must exclude the crywrap wrapper (uses fork)
+GNUTLS_CONF_OPT += $(if $(BR2_USE_MMU),,--disable-crywrap)
+GNUTLS_DEPENDENCIES += $(if $(BR2_PACKAGE_LIBIDN),libidn)
+
# Some examples in doc/examples use wchar
define GNUTLS_DISABLE_DOCS
$(SED) 's/ doc / /' $(@D)/Makefile.in