summaryrefslogtreecommitdiffstats
path: root/package/gnutls
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavo@zacarias.com.ar>2013-01-02 04:50:09 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-01-02 15:52:49 +0100
commit50e562bc4ab83128f093f44b34327f8c23782b06 (patch)
tree4e336c557b4885390478cb973dc210e689fadd40 /package/gnutls
parent5406b810d032efbabd09e767c16324b912750d46 (diff)
downloadbuildroot-novena-50e562bc4ab83128f093f44b34327f8c23782b06.tar.gz
buildroot-novena-50e562bc4ab83128f093f44b34327f8c23782b06.zip
gnutls: fix build failure related to pthreads
The pthreads autodetection poisons the linkpath thus making other distribution libraries to take precedence over the cross ones. Leading to failures such as: http://autobuild.buildroot.net/results/tmp/3f979d4e2186ee31012c332fedec9591890b0b77 Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/gnutls')
-rw-r--r--package/gnutls/gnutls.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/gnutls/gnutls.mk b/package/gnutls/gnutls.mk
index 0166a7415..1cbcf7021 100644
--- a/package/gnutls/gnutls.mk
+++ b/package/gnutls/gnutls.mk
@@ -17,6 +17,9 @@ GNUTLS_CONF_ENV = gl_cv_socket_ipv6=$(if $(BR2_INET_IPV6),yes,no) \
gt_cv_c_wint_t=$(if $(BR2_USE_WCHAR),yes,no)
GNUTLS_INSTALL_STAGING = YES
+# libpthread autodetection poisons the linkpath
+GNUTLS_CONF_OPT += $(if $(BR2_TOOLCHAIN_HAS_THREADS),--with-libpthread-prefix=$(STAGING_DIR)/usr)
+
# Some examples in doc/examples use wchar
define GNUTLS_DISABLE_DOCS
$(SED) 's/ doc / /' $(@D)/Makefile.in