summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2013-03-26 08:33:18 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-26 08:33:18 +0100
commit13c07c79a401a8821b3224bc00c60c097f011add (patch)
tree8711f8d80530541568d702f4aefc26638cd5fe48 /Makefile
parent1cd3f992fb3659aacbb0cdd3ed64347a37569891 (diff)
downloadbuildroot-novena-13c07c79a401a8821b3224bc00c60c097f011add.tar.gz
buildroot-novena-13c07c79a401a8821b3224bc00c60c097f011add.zip
Makefile: simplify target skeleton copying
We already use the .root stamp file to remember if we have copied the skeleton, so we can remove the /bin check. Likewise, we should always have a TARGET_SKELETON (or explicitly error out otherwise), so remove that check as well. Finally, now that we're using rsync to do the copy, we might as well use its exclude support instead of cleaning up unwanted files afterwards. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 62311ede3..c95bb1e92 100644
--- a/Makefile
+++ b/Makefile
@@ -429,14 +429,9 @@ endif
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
- if ! [ -d "$(TARGET_DIR)/bin" ]; then \
- if [ -d "$(TARGET_SKELETON)" ]; then \
- rsync -au $(TARGET_SKELETON)/ $(TARGET_DIR)/; \
- fi; \
- fi
+ rsync -au --exclude=.empty --exclude=CVS --exclude=.svn --exclude='*~' \
+ $(TARGET_SKELETON)/ $(TARGET_DIR)/
cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
- -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
- -find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
touch $@
$(TARGET_DIR): $(BUILD_DIR)/.root