summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile b/Makefile
index 62311ede3..c95bb1e92 100644
--- a/Makefile
+++ b/Makefile
@@ -429,14 +429,9 @@ endif
$(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
- if ! [ -d "$(TARGET_DIR)/bin" ]; then \
- if [ -d "$(TARGET_SKELETON)" ]; then \
- rsync -au $(TARGET_SKELETON)/ $(TARGET_DIR)/; \
- fi; \
- fi
+ rsync -au --exclude=.empty --exclude=CVS --exclude=.svn --exclude='*~' \
+ $(TARGET_SKELETON)/ $(TARGET_DIR)/
cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)
- -find $(TARGET_DIR) -type d -name CVS -print0 -o -name .svn -print0 | xargs -0 rm -rf
- -find $(TARGET_DIR) -type f \( -name .empty -o -name '*~' \) -print0 | xargs -0 rm -rf
touch $@
$(TARGET_DIR): $(BUILD_DIR)/.root