summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorTilman Keskinöz <arved@arved.at>2013-03-25 04:48:11 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-03-25 23:38:26 +0100
commit1cd3f992fb3659aacbb0cdd3ed64347a37569891 (patch)
tree139ad4ef3307310e3cbb59edc2f943cd0428851f /Makefile
parentd26c729845a9e04e871f88878fa3916c7ab272b0 (diff)
downloadbuildroot-novena-1cd3f992fb3659aacbb0cdd3ed64347a37569891.tar.gz
buildroot-novena-1cd3f992fb3659aacbb0cdd3ed64347a37569891.zip
Support .dotfiles in / being copied to the TARGET
An example is .init_enable_core, to enable coredumps in busybox Signed-off-by: Tilman Keskinöz <arved@arved.at> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile b/Makefile
index f1c98aa93..62311ede3 100644
--- a/Makefile
+++ b/Makefile
@@ -431,7 +431,7 @@ $(BUILD_DIR)/.root:
mkdir -p $(TARGET_DIR)
if ! [ -d "$(TARGET_DIR)/bin" ]; then \
if [ -d "$(TARGET_SKELETON)" ]; then \
- cp -fa $(TARGET_SKELETON)/* $(TARGET_DIR)/; \
+ rsync -au $(TARGET_SKELETON)/ $(TARGET_DIR)/; \
fi; \
fi
cp support/misc/target-dir-warning.txt $(TARGET_DIR_WARNING_FILE)