aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 1833fed..30bfbaf 100644
--- a/setup.py
+++ b/setup.py
@@ -26,21 +26,19 @@ with open("README.md", "r") as fh:
"fuzzycat=fuzzycat.main:main"
]},
install_requires=[
+ "elasticsearch",
+ "elasticsearch-dsl",
+ "fatcat-openapi-client", # https://pypi.org/project/fatcat-openapi-client/
"ftfy",
"fuzzy",
- "pydantic",
+ "glom",
"toml",
"unidecode>=0.10",
- "fatcat-openapi-client", # https://pypi.org/project/fatcat-openapi-client/
- "elasticsearch",
- "elasticsearch-dsl",
],
extras_require={"dev": [
"ipython",
"isort",
- "jupyter",
- "matplotlib",
- "pandas",
+ "mypy",
"pylint",
"pytest",
"pytest-cov",