aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Czygan <martin.czygan@gmail.com>2020-12-16 02:50:10 +0100
committerMartin Czygan <martin.czygan@gmail.com>2020-12-16 02:50:10 +0100
commit3549cc0333a99ab2d7dbca695f58c4a51a9ad9e8 (patch)
treee44b04ee7711e2bb2d53a311d235ec46afe9b10e /setup.py
parent3f79c65e6bbd85628cfba56b3c259929d376aa82 (diff)
downloadfuzzycat-3549cc0333a99ab2d7dbca695f58c4a51a9ad9e8.tar.gz
fuzzycat-3549cc0333a99ab2d7dbca695f58c4a51a9ad9e8.zip
cleanup deps
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py12
1 files changed, 5 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index 1833fed..30bfbaf 100644
--- a/setup.py
+++ b/setup.py
@@ -26,21 +26,19 @@ with open("README.md", "r") as fh:
"fuzzycat=fuzzycat.main:main"
]},
install_requires=[
+ "elasticsearch",
+ "elasticsearch-dsl",
+ "fatcat-openapi-client", # https://pypi.org/project/fatcat-openapi-client/
"ftfy",
"fuzzy",
- "pydantic",
+ "glom",
"toml",
"unidecode>=0.10",
- "fatcat-openapi-client", # https://pypi.org/project/fatcat-openapi-client/
- "elasticsearch",
- "elasticsearch-dsl",
],
extras_require={"dev": [
"ipython",
"isort",
- "jupyter",
- "matplotlib",
- "pandas",
+ "mypy",
"pylint",
"pytest",
"pytest-cov",