aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMartin Czygan <martin.czygan@gmail.com>2020-08-17 17:30:28 +0200
committerMartin Czygan <martin.czygan@gmail.com>2020-08-17 17:30:28 +0200
commit3cdd049998ed85827dc6339725ea8fdda5a700aa (patch)
treec243547543cdbe11d235a13af42e016e633f6c6e /setup.py
parent5084ca9fe10b4c58afc28370d98cf3e798bd2109 (diff)
downloadfuzzycat-3cdd049998ed85827dc6339725ea8fdda5a700aa.tar.gz
fuzzycat-3cdd049998ed85827dc6339725ea8fdda5a700aa.zip
large overhaul
* separate all fatcat related code into fatcat submodule * more type annotations * add verify_serial_name for journal names
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index e2ff44b..25ccc46 100644
--- a/setup.py
+++ b/setup.py
@@ -23,18 +23,20 @@ with open("README.md", "r") as fh:
python_requires=">=3.6",
zip_safe=False,
entry_points={"console_scripts": [
- "fuzzycat=fuzzycat.main:main",
"fuzzycat-issn=fuzzycat.issn:main",
],},
install_requires=[
"fatcat-openapi-client",
"ftfy",
"simhash",
- "unidecode",
+ "unidecode>=0.10",
+ "toml",
+ "elasticsearch>=7",
],
extras_require={"dev": [
"ipython",
"isort",
+ "pylint",
"jupyter",
"matplotlib",
"pandas",