aboutsummaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@archive.org>2020-12-23 16:11:56 -0800
committerBryan Newbold <bnewbold@archive.org>2020-12-23 16:17:31 -0800
commitbc923738c149767d6804a87555cdf0ce2a8fff4f (patch)
tree1251da2480f3ef1592a8597b5c9d9cbebd7fe1d2 /Cargo.toml
parentd77c0fb78fa106fea6f7b04195d94d5f1e9fe2da (diff)
downloades-public-proxy-bc923738c149767d6804a87555cdf0ce2a8fff4f.tar.gz
es-public-proxy-bc923738c149767d6804a87555cdf0ce2a8fff4f.zip
update to hyper 0.14 and tokio 1.0
Also run `cargo upgrade` broadly
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml10
1 files changed, 5 insertions, 5 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 0f71753..3084cc4 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,6 +1,6 @@
[package]
name = "es-public-proxy"
-version = "0.2.4"
+version = "0.2.5"
edition = "2018"
authors = ["Bryan Newbold <bnewbold@robocracy.org>"]
license = "AGPL-3.0-or-later"
@@ -12,11 +12,11 @@ keywords = ["elasticsearch", "proxy"]
categories = ["command-line-utilities"]
[dependencies]
-hyper = "0.13"
+hyper = { version = "0.14", features = ["client", "server", "http1", "runtime"] }
http = "0.2"
-tokio = { version = "0.2", features = ["rt-threaded", "tcp", "signal", "macros"] }
-serde = { version = "1.0", features = ["derive"] }
-serde_json = "1.0"
+tokio = { version = "1", features = ["rt-multi-thread", "net", "signal", "macros"] }
+serde = { version = "1", features = ["derive"] }
+serde_json = "1"
serde_urlencoded = "0.5"
toml = "0.4"
log = "0.4"