aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Bushnell <tb@debian.org>2008-07-26 12:08:17 -0700
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:42 -0800
commit7bfc213c637ef0dc28f6a99b0528978159e0c54f (patch)
treec8b3fd5be9240fe0a11b1cc9880a5ce766ce3075
parent978a3689f0198999230fee96c037cf3f2f5207d9 (diff)
downloadscm-7bfc213c637ef0dc28f6a99b0528978159e0c54f.tar.gz
scm-7bfc213c637ef0dc28f6a99b0528978159e0c54f.zip
Import Debian changes 5e5-3debian/5e5-3
scm (5e5-3) unstable; urgency=low * build.scm (build-continue-ia64): New function, to encapsulate the method for building continue-ia64.o. (link-c-program/linux-ia64): Use build-continue-ia64. (make-archive/linux-ia64): New command, to use build-continue-ia64. (Closes: #483273).
-rw-r--r--build.scm24
-rw-r--r--debian/changelog10
2 files changed, 28 insertions, 6 deletions
diff --git a/build.scm b/build.scm
index 7ea579c..c991ec4 100644
--- a/build.scm
+++ b/build.scm
@@ -1087,14 +1087,17 @@
(append objects libs)))
oname)))
+(define (build-continue-ia64 parms)
+ (and (batch:try-command
+ parms "gcc -o get-contoffset-ia64 get-contoffset-ia64.c")
+ (batch:try-command
+ parms "./get-contoffset-ia64 contoffset-ia64.S")
+ (batch:try-command
+ parms "gcc -c continue-ia64.S")))
+
(defcommand link-c-program linux-ia64
(lambda (oname objects libs parms)
- (and (and (batch:try-command
- parms "gcc -o get-contoffset-ia64 get-contoffset-ia64.c")
- (batch:try-command
- parms "./get-contoffset-ia64 contoffset-ia64.S")
- (batch:try-command
- parms "gcc -c continue-ia64.S"))
+ (and (build-continue-ia64 parms)
(batch:try-command
parms "gcc" "-rdynamic" "-o" oname "continue-ia64.o"
(must-be-first
@@ -1578,6 +1581,15 @@
(and (batch:try-command parms "ar rc" aname objects)
(batch:try-command parms "ranlib" aname)
aname))))
+
+(defcommand make-archive linux-ia64
+ (lambda (oname objects libs parms)
+ (let ((aname (string-append "lib" oname ".a")))
+ (and (build-continue-ia64 parms)
+ (batch:try-command parms "ar rc" aname objects "continue-ia64.o")
+ (batch:try-command parms "ranlib" aname)
+ aname))))
+
(defcommand compile-dll-c-files *unknown*
(lambda (files parms)
(and (batch:try-chopped-command parms
diff --git a/debian/changelog b/debian/changelog
index 5a5fcc4..60fd780 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,13 @@
+scm (5e5-3) unstable; urgency=low
+
+ * build.scm (build-continue-ia64): New function, to encapsulate the method
+ for building continue-ia64.o.
+ (link-c-program/linux-ia64): Use build-continue-ia64.
+ (make-archive/linux-ia64): New command, to use build-continue-ia64.
+ (Closes: #483273).
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Sat, 26 Jul 2008 12:08:17 -0700
+
scm (5e5-2) unstable; urgency=low
* continue.h: actually make the change mentioned in 5e5-1.