diff options
author | Thomas Bushnell <tb@debian.org> | 2008-02-18 15:37:29 -0500 |
---|---|---|
committer | Bryan Newbold <bnewbold@robocracy.org> | 2017-02-20 00:05:41 -0800 |
commit | 978a3689f0198999230fee96c037cf3f2f5207d9 (patch) | |
tree | 910512ad3fa92f22ccf6503c45768d6ae296dae0 | |
parent | e9ed1ad5236ca6314136c4220ac672167b643fc5 (diff) | |
download | scm-978a3689f0198999230fee96c037cf3f2f5207d9.tar.gz scm-978a3689f0198999230fee96c037cf3f2f5207d9.zip |
Import Debian changes 5e5-2debian/5e5-2
scm (5e5-2) unstable; urgency=low
* continue.h: actually make the change mentioned in 5e5-1.
* Makefile: Likewise.
* xgen.scm: Likewise.
* scm.1: Likewise.
* build.scm: Likewise.
-rw-r--r-- | Makefile | 4 | ||||
-rw-r--r-- | build.scm | 10 | ||||
-rw-r--r-- | continue.h | 4 | ||||
-rw-r--r-- | debian/changelog | 10 | ||||
-rw-r--r-- | scm.1 | 2 | ||||
-rwxr-xr-x | xgen.scm | 2 |
6 files changed, 29 insertions, 3 deletions
@@ -89,7 +89,9 @@ ufiles = pre-crt0.c ecrt0.c gmalloc.c unexec.c unexelf.c unexhp9k800.c \ # unexnext.c unexnt.c unexsgi.c unexsni.c unexsunos4.c ofiles = scm.o time.o repl.o scl.o sys.o eval.o subr.o unif.o rope.o \ continue.o findexec.o script.o debug.o -# continue-ia64.o +ifeq ($(ARCH),ia64) +ofiles += continue-ia64.o +endif ifiles = Init$(VERSION).scm Transcen.scm Link.scm Macro.scm Macexp.scm \ Tscript.scm compile.scm Iedline.scm Idiffer.scm hobfiles = hobbit.scm scmhob.scm scmhob.h @@ -568,6 +568,16 @@ (nostart linux "" "" #f () ()) (dump linux "" "" #f ("unexelf.c" "gmalloc.c") ()) + (m linux-ia64 "" "-lm" "/lib/libm.so" () ()) + (c linux-ia64 "" "-lc" "/lib/libc.so" () ()) + (dlll linux-ia64 "-DSUN_DL" "-ldl" #f () ()) + (regex linux-ia64 "" "" #f () ()) + (graphics linux-ia64 "-I/usr/include/X11 -DX11" "-L/usr/X11R6/lib -lX11" + "/usr/X11R6/lib/libX11.so" () ()) + (curses linux-ia64 "" "-lcurses" "/lib/libncurses.so" () ()) + (nostart linux-ia64 "" "" #f () ()) + (dump linux-ia64 "" "" #f ("unexelf.c" "gmalloc.c") ()) + (dump irix "" "-G 0" #f () ()) (m acorn-unixlib "" "" #f () ()) @@ -60,6 +60,10 @@ typedef long STACKITEM; #ifdef _UNICOS # define STACK_GROWS_UP #endif +/* __hppa__ case added by tb for debian */ +#ifdef __hppa__ +# define STACK_GROWS_UP +#endif /* James Clark came up with this neat one instruction fix for continuations on the SPARC. It flushes the register windows so diff --git a/debian/changelog b/debian/changelog index 7389b4e..5a5fcc4 100644 --- a/debian/changelog +++ b/debian/changelog @@ -1,3 +1,13 @@ +scm (5e5-2) unstable; urgency=low + + * continue.h: actually make the change mentioned in 5e5-1. + * Makefile: Likewise. + * xgen.scm: Likewise. + * scm.1: Likewise. + * build.scm: Likewise. + + -- Thomas Bushnell, BSG <tb@debian.org> Mon, 18 Feb 2008 15:37:29 -0500 + scm (5e5-1) unstable; urgency=low * New upstream release. @@ -1,5 +1,5 @@ .\" dummy line -.TH SCM "April 2006" +.TH 1 SCM "April 2006" .UC 4 .SH NAME scm \- a Scheme Language Interpreter @@ -1,4 +1,4 @@ -#! /usr/local/bin/scm \ %0 %* +#! /usr/bin/scm \ %0 %* - !# ;;;; "xgen.scm", Convert C Event structs to xevent.h and xevent.scm. ;; Copyright (C) 1991-2000 Free Software Foundation, Inc. |