summaryrefslogtreecommitdiffstats
path: root/package/arptables/arptables.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/arptables/arptables.mk')
-rw-r--r--package/arptables/arptables.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/arptables/arptables.mk b/package/arptables/arptables.mk
new file mode 100644
index 000000000..dac5ca470
--- /dev/null
+++ b/package/arptables/arptables.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# arptables
+#
+#############################################################
+
+ARPTABLES_VERSION = 0.0.3
+ARPTABLES_VERSION_MINOR = 4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
+ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
+
+define ARPTABLES_BUILD_CMDS
+ $(MAKE) -C $(@D) \
+ CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)"
+endef
+
+define ARPTABLES_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/arptables $(TARGET_DIR)/usr/sbin/arptables
+endef
+
+$(eval $(generic-package))