summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--package/Config.in1
-rw-r--r--package/arptables/Config.in6
-rw-r--r--package/arptables/arptables.mk21
3 files changed, 28 insertions, 0 deletions
diff --git a/package/Config.in b/package/Config.in
index 3b7458f17..6125abcb8 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -550,6 +550,7 @@ endmenu
menu "Networking applications"
source "package/argus/Config.in"
+source "package/arptables/Config.in"
source "package/avahi/Config.in"
source "package/axel/Config.in"
source "package/bluez_utils/Config.in"
diff --git a/package/arptables/Config.in b/package/arptables/Config.in
new file mode 100644
index 000000000..510eedf3b
--- /dev/null
+++ b/package/arptables/Config.in
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_ARPTABLES
+ bool "arptables"
+ help
+ Tool to set up, maintain, and inspect the tables of ARP rules.
+
+ http://ebtables.sourceforge.net
diff --git a/package/arptables/arptables.mk b/package/arptables/arptables.mk
new file mode 100644
index 000000000..dac5ca470
--- /dev/null
+++ b/package/arptables/arptables.mk
@@ -0,0 +1,21 @@
+#############################################################
+#
+# arptables
+#
+#############################################################
+
+ARPTABLES_VERSION = 0.0.3
+ARPTABLES_VERSION_MINOR = 4
+ARPTABLES_SOURCE = arptables-v$(ARPTABLES_VERSION)-$(ARPTABLES_VERSION_MINOR).tar.gz
+ARPTABLES_SITE = http://downloads.sourceforge.net/project/ebtables/arptables/arptables-v$(ARPTABLES_VERSION)
+
+define ARPTABLES_BUILD_CMDS
+ $(MAKE) -C $(@D) \
+ CC="$(TARGET_CC)" COPT_FLAGS="$(TARGET_CFLAGS)"
+endef
+
+define ARPTABLES_INSTALL_TARGET_CMDS
+ $(INSTALL) -m 755 -D $(@D)/arptables $(TARGET_DIR)/usr/sbin/arptables
+endef
+
+$(eval $(generic-package))