summaryrefslogtreecommitdiffstats
path: root/package/yasm
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:33:25 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-09-03 21:59:03 +0200
commit32a0454d3c495b12824ef4a0d0341237302d148a (patch)
tree9acc870d089b0028cecdfb1846b828ae4bd38910 /package/yasm
parentf9686563b4fd3eed22e26105f7c440f0b74fcac1 (diff)
parentdafa32b3bd75e9d155d075c796fa5b0ecbb9b11b (diff)
downloadbuildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.tar.gz
buildroot-novena-32a0454d3c495b12824ef4a0d0341237302d148a.zip
Merge branch 'next'
Conflicts: package/e2fsprogs/e2fsprogs.mk package/libfuse/libfuse.mk package/multimedia/mpd/mpd.mk package/smartmontools/smartmontools.mk Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/yasm')
-rw-r--r--package/yasm/Config.in10
-rw-r--r--package/yasm/yasm.mk20
2 files changed, 30 insertions, 0 deletions
diff --git a/package/yasm/Config.in b/package/yasm/Config.in
new file mode 100644
index 000000000..2dc25aadb
--- /dev/null
+++ b/package/yasm/Config.in
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_YASM
+ bool "yasm"
+ depends on BR2_i386 || BR2_x86_64
+ help
+ Yasm is a complete rewrite of the NASM-2.10.01 assembler.
+ It supports the x86 and AMD64 instruction sets, accepts NASM
+ and GAS assembler syntaxes and outputs binary, ELF32 and ELF64
+ object formats.
+
+ http://www.tortall.net/projects/yasm/
diff --git a/package/yasm/yasm.mk b/package/yasm/yasm.mk
new file mode 100644
index 000000000..fafd1ec6d
--- /dev/null
+++ b/package/yasm/yasm.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# yasm
+#
+#############################################################
+YASM_VERSION = 1.2.0
+YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
+YASM_SITE = http://www.tortall.net/projects/yasm/releases/
+
+define YASM_PRE_CONFIGURE_FIXUP
+# This sed prevents it compiling 2 programs (vsyasm and ytasm)
+# that are only of use on Microsoft Windows.
+ sed -i 's#) ytasm.*#)#' $(@D)/Makefile.in
+endef
+
+YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+HOST_YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))