summaryrefslogtreecommitdiffstats
path: root/package/yasm/yasm.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/yasm/yasm.mk')
-rw-r--r--package/yasm/yasm.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/yasm/yasm.mk b/package/yasm/yasm.mk
new file mode 100644
index 000000000..fafd1ec6d
--- /dev/null
+++ b/package/yasm/yasm.mk
@@ -0,0 +1,20 @@
+#############################################################
+#
+# yasm
+#
+#############################################################
+YASM_VERSION = 1.2.0
+YASM_SOURCE = yasm-$(YASM_VERSION).tar.gz
+YASM_SITE = http://www.tortall.net/projects/yasm/releases/
+
+define YASM_PRE_CONFIGURE_FIXUP
+# This sed prevents it compiling 2 programs (vsyasm and ytasm)
+# that are only of use on Microsoft Windows.
+ sed -i 's#) ytasm.*#)#' $(@D)/Makefile.in
+endef
+
+YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+HOST_YASM_PRE_CONFIGURE_HOOKS += YASM_PRE_CONFIGURE_FIXUP
+
+$(eval $(autotools-package))
+$(eval $(host-autotools-package))