summaryrefslogtreecommitdiffstats
path: root/fs/ubifs/ubifsroot.mk
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec /fs/ubifs/ubifsroot.mk
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'fs/ubifs/ubifsroot.mk')
-rw-r--r--fs/ubifs/ubifsroot.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/fs/ubifs/ubifsroot.mk b/fs/ubifs/ubifsroot.mk
new file mode 100644
index 000000000..0fad23421
--- /dev/null
+++ b/fs/ubifs/ubifsroot.mk
@@ -0,0 +1,25 @@
+#############################################################
+#
+# Build the ubifs root filesystem image
+#
+#############################################################
+
+UBIFS_OPTS := -e $(BR2_TARGET_ROOTFS_UBIFS_LEBSIZE) -c $(BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT) -m $(BR2_TARGET_ROOTFS_UBIFS_MINIOSIZE)
+
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_ZLIB),y)
+UBIFS_OPTS += -x zlib
+endif
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_LZI),y)
+UBIFS_OPTS += -x lzo
+endif
+ifeq ($(BR2_TARGET_ROOTFS_UBIFS_RT_NONE),y)
+UBIFS_OPTS += -x none
+endif
+
+ROOTFS_UBIFS_DEPENDENCIES = host-mtd
+
+define ROOTFS_UBIFS_CMD
+ $(HOST_DIR)/usr/sbin/mkfs.ubifs -d $(TARGET_DIR) $(UBIFS_OPTS) -o $$@
+endef
+
+$(eval $(call ROOTFS_TARGET,ubifs)) \ No newline at end of file