summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-10 22:30:06 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:04:36 +0200
commit0585241505cfaddc9db6ae92739bdfb5ce5f9794 (patch)
tree8fb56f7d4ba91b0384e522c10ed9dbdb77dfe7ec
parent325bfd1cbae03fe286796d3fa7de7c0a3227f7a5 (diff)
downloadbuildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.tar.gz
buildroot-novena-0585241505cfaddc9db6ae92739bdfb5ce5f9794.zip
Move all filesystem generation code to fs/
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
-rw-r--r--Config.in2
-rw-r--r--Makefile2
-rw-r--r--fs/Config.in30
-rw-r--r--fs/cloop/Config.in (renamed from target/cloop/Config.in)0
-rw-r--r--fs/cloop/cloop.mk (renamed from target/cloop/cloop.mk)0
-rw-r--r--fs/common.mk (renamed from target/common.mk)2
-rw-r--r--fs/cpio/Config.in (renamed from target/cpio/Config.in)0
-rw-r--r--fs/cpio/cpioroot.mk (renamed from target/cpio/cpioroot.mk)0
-rw-r--r--fs/cramfs/Config.in (renamed from target/cramfs/Config.in)0
-rw-r--r--fs/cramfs/cramfs.mk (renamed from target/cramfs/cramfs.mk)0
-rw-r--r--fs/ext2/Config.in (renamed from target/ext2/Config.in)0
-rw-r--r--fs/ext2/ext2root.mk (renamed from target/ext2/ext2root.mk)0
-rw-r--r--fs/initramfs/Config.in (renamed from target/initramfs/Config.in)0
-rw-r--r--fs/initramfs/gen_initramfs_list.sh (renamed from target/initramfs/gen_initramfs_list.sh)0
-rw-r--r--fs/initramfs/initramfs.mk (renamed from target/initramfs/initramfs.mk)0
-rw-r--r--fs/iso9660/Config.in (renamed from target/iso9660/Config.in)0
-rw-r--r--fs/iso9660/iso9660.mk (renamed from target/iso9660/iso9660.mk)0
-rw-r--r--fs/iso9660/menu.lst (renamed from target/iso9660/menu.lst)0
-rw-r--r--fs/jffs2/Config.in (renamed from target/jffs2/Config.in)0
-rw-r--r--fs/jffs2/jffs2root.mk (renamed from target/jffs2/jffs2root.mk)0
-rw-r--r--fs/romfs/Config.in (renamed from target/romfs/Config.in)0
-rw-r--r--fs/romfs/romfs.mk (renamed from target/romfs/romfs.mk)0
-rw-r--r--fs/squashfs/Config.in (renamed from target/squashfs/Config.in)0
-rw-r--r--fs/squashfs/squashfsroot.mk (renamed from target/squashfs/squashfsroot.mk)0
-rw-r--r--fs/tar/Config.in (renamed from target/tar/Config.in)0
-rw-r--r--fs/tar/tarroot.mk (renamed from target/tar/tarroot.mk)0
-rw-r--r--fs/ubifs/Config.in (renamed from target/ubifs/Config.in)0
-rw-r--r--fs/ubifs/ubifsroot.mk (renamed from target/ubifs/ubifsroot.mk)0
-rw-r--r--target/Config.in33
-rw-r--r--target/Makefile.in2
30 files changed, 37 insertions, 34 deletions
diff --git a/Config.in b/Config.in
index 4f567d007..224a44ae2 100644
--- a/Config.in
+++ b/Config.in
@@ -346,4 +346,6 @@ source "toolchain/Config.in"
source "package/Config.in"
+source "fs/Config.in"
+
source "target/Config.in"
diff --git a/Makefile b/Makefile
index b47c0b0dd..ce6bf3d4c 100644
--- a/Makefile
+++ b/Makefile
@@ -323,6 +323,8 @@ ifeq ($(BR2_ENABLE_LOCALE_PURGE),y)
TARGETS+=target-purgelocales
endif
+include fs/common.mk
+
# target stuff is last so it can override anything else
include target/Makefile.in
diff --git a/fs/Config.in b/fs/Config.in
new file mode 100644
index 000000000..f885c52e7
--- /dev/null
+++ b/fs/Config.in
@@ -0,0 +1,30 @@
+menu "Target filesystem options"
+
+config BR2_ROOTFS_POST_BUILD_SCRIPT
+ string "Custom script to run before packing files"
+ default ""
+ help
+ Specify a script to be run after the build has finished and before
+ the BR2 starts packing the files into selected packages.
+
+ This gives users the oportunity to do board-specific cleanups,
+ add-ons and the like, so the generated files can be used directly
+ without further processing.
+
+ The script is called with the target directory name as first and
+ only argument. Make sure the exit code of that script is 0,
+ otherwise make will stop after calling it.
+
+source "fs/cramfs/Config.in"
+source "fs/cloop/Config.in"
+source "fs/ext2/Config.in"
+source "fs/jffs2/Config.in"
+source "fs/ubifs/Config.in"
+source "fs/squashfs/Config.in"
+source "fs/tar/Config.in"
+source "fs/cpio/Config.in"
+source "fs/iso9660/Config.in"
+source "fs/initramfs/Config.in"
+source "fs/romfs/Config.in"
+
+endmenu
diff --git a/target/cloop/Config.in b/fs/cloop/Config.in
index 3e01067a1..3e01067a1 100644
--- a/target/cloop/Config.in
+++ b/fs/cloop/Config.in
diff --git a/target/cloop/cloop.mk b/fs/cloop/cloop.mk
index c1d6abb80..c1d6abb80 100644
--- a/target/cloop/cloop.mk
+++ b/fs/cloop/cloop.mk
diff --git a/target/common.mk b/fs/common.mk
index cebe8c34a..fa6afd94d 100644
--- a/target/common.mk
+++ b/fs/common.mk
@@ -66,3 +66,5 @@ endef
define ROOTFS_TARGET
$(call ROOTFS_TARGET_INTERNAL,$(1),$(call UPPERCASE,$(1)))
endef
+
+include fs/*/*.mk
diff --git a/target/cpio/Config.in b/fs/cpio/Config.in
index 02fd00d34..02fd00d34 100644
--- a/target/cpio/Config.in
+++ b/fs/cpio/Config.in
diff --git a/target/cpio/cpioroot.mk b/fs/cpio/cpioroot.mk
index ab7d54618..ab7d54618 100644
--- a/target/cpio/cpioroot.mk
+++ b/fs/cpio/cpioroot.mk
diff --git a/target/cramfs/Config.in b/fs/cramfs/Config.in
index 1a4e32647..1a4e32647 100644
--- a/target/cramfs/Config.in
+++ b/fs/cramfs/Config.in
diff --git a/target/cramfs/cramfs.mk b/fs/cramfs/cramfs.mk
index ccd316f5d..ccd316f5d 100644
--- a/target/cramfs/cramfs.mk
+++ b/fs/cramfs/cramfs.mk
diff --git a/target/ext2/Config.in b/fs/ext2/Config.in
index 02ec18f40..02ec18f40 100644
--- a/target/ext2/Config.in
+++ b/fs/ext2/Config.in
diff --git a/target/ext2/ext2root.mk b/fs/ext2/ext2root.mk
index 68b3b813c..68b3b813c 100644
--- a/target/ext2/ext2root.mk
+++ b/fs/ext2/ext2root.mk
diff --git a/target/initramfs/Config.in b/fs/initramfs/Config.in
index d53982cb9..d53982cb9 100644
--- a/target/initramfs/Config.in
+++ b/fs/initramfs/Config.in
diff --git a/target/initramfs/gen_initramfs_list.sh b/fs/initramfs/gen_initramfs_list.sh
index 26252b619..26252b619 100644
--- a/target/initramfs/gen_initramfs_list.sh
+++ b/fs/initramfs/gen_initramfs_list.sh
diff --git a/target/initramfs/initramfs.mk b/fs/initramfs/initramfs.mk
index cf1fcdbae..cf1fcdbae 100644
--- a/target/initramfs/initramfs.mk
+++ b/fs/initramfs/initramfs.mk
diff --git a/target/iso9660/Config.in b/fs/iso9660/Config.in
index ceee52ff9..ceee52ff9 100644
--- a/target/iso9660/Config.in
+++ b/fs/iso9660/Config.in
diff --git a/target/iso9660/iso9660.mk b/fs/iso9660/iso9660.mk
index 66e2de20b..66e2de20b 100644
--- a/target/iso9660/iso9660.mk
+++ b/fs/iso9660/iso9660.mk
diff --git a/target/iso9660/menu.lst b/fs/iso9660/menu.lst
index d78caebe1..d78caebe1 100644
--- a/target/iso9660/menu.lst
+++ b/fs/iso9660/menu.lst
diff --git a/target/jffs2/Config.in b/fs/jffs2/Config.in
index b787ec9d1..b787ec9d1 100644
--- a/target/jffs2/Config.in
+++ b/fs/jffs2/Config.in
diff --git a/target/jffs2/jffs2root.mk b/fs/jffs2/jffs2root.mk
index a0a563d18..a0a563d18 100644
--- a/target/jffs2/jffs2root.mk
+++ b/fs/jffs2/jffs2root.mk
diff --git a/target/romfs/Config.in b/fs/romfs/Config.in
index 7a8c663dd..7a8c663dd 100644
--- a/target/romfs/Config.in
+++ b/fs/romfs/Config.in
diff --git a/target/romfs/romfs.mk b/fs/romfs/romfs.mk
index 971947880..971947880 100644
--- a/target/romfs/romfs.mk
+++ b/fs/romfs/romfs.mk
diff --git a/target/squashfs/Config.in b/fs/squashfs/Config.in
index 6cc8fcae0..6cc8fcae0 100644
--- a/target/squashfs/Config.in
+++ b/fs/squashfs/Config.in
diff --git a/target/squashfs/squashfsroot.mk b/fs/squashfs/squashfsroot.mk
index d72388ebf..d72388ebf 100644
--- a/target/squashfs/squashfsroot.mk
+++ b/fs/squashfs/squashfsroot.mk
diff --git a/target/tar/Config.in b/fs/tar/Config.in
index 0adca795f..0adca795f 100644
--- a/target/tar/Config.in
+++ b/fs/tar/Config.in
diff --git a/target/tar/tarroot.mk b/fs/tar/tarroot.mk
index 4d435cb33..4d435cb33 100644
--- a/target/tar/tarroot.mk
+++ b/fs/tar/tarroot.mk
diff --git a/target/ubifs/Config.in b/fs/ubifs/Config.in
index 9fa510e75..9fa510e75 100644
--- a/target/ubifs/Config.in
+++ b/fs/ubifs/Config.in
diff --git a/target/ubifs/ubifsroot.mk b/fs/ubifs/ubifsroot.mk
index 0fad23421..0fad23421 100644
--- a/target/ubifs/ubifsroot.mk
+++ b/fs/ubifs/ubifsroot.mk
diff --git a/target/Config.in b/target/Config.in
index 5d634ca2a..5d5363538 100644
--- a/target/Config.in
+++ b/target/Config.in
@@ -1,35 +1,4 @@
-menu "Target filesystem options"
-
-config BR2_ROOTFS_POST_BUILD_SCRIPT
- string "Custom script to run before packing files"
- default ""
- help
- Specify a script to be run after the build has finished and before
- the BR2 starts packing the files into selected packages.
-
- This gives users the oportunity to do board-specific cleanups,
- add-ons and the like, so the generated files can be used directly
- without further processing.
-
- The script is called with the target directory name as first and
- only argument. Make sure the exit code of that script is 0,
- otherwise make will stop after calling it.
-
-comment "filesystem for target device"
-
-source "target/cramfs/Config.in"
-source "target/cloop/Config.in"
-source "target/ext2/Config.in"
-source "target/jffs2/Config.in"
-source "target/ubifs/Config.in"
-source "target/squashfs/Config.in"
-source "target/tar/Config.in"
-source "target/cpio/Config.in"
-source "target/iso9660/Config.in"
-source "target/initramfs/Config.in"
-source "target/romfs/Config.in"
-
-comment "bootloader for target device"
+menu "Bootloaders"
source "target/x86/grub/Config.in"
#source "target/x86/grub2/Config.in"
diff --git a/target/Makefile.in b/target/Makefile.in
index 38993e5d8..48396d5d8 100644
--- a/target/Makefile.in
+++ b/target/Makefile.in
@@ -62,8 +62,6 @@ ifeq ($(BR2_TARGET_UBOOT),y)
include target/u-boot/Makefile.in
endif
-# and finally build the filesystems/tarballs
-include target/common.mk
include target/*/*.mk
# kernel rules