summaryrefslogtreecommitdiffstats
path: root/fs/tar/tarroot.mk
diff options
context:
space:
mode:
Diffstat (limited to 'fs/tar/tarroot.mk')
-rw-r--r--fs/tar/tarroot.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/fs/tar/tarroot.mk b/fs/tar/tarroot.mk
new file mode 100644
index 000000000..4d435cb33
--- /dev/null
+++ b/fs/tar/tarroot.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# tar to archive target filesystem
+#
+#############################################################
+
+TAR_OPTS:=$(BR2_TARGET_ROOTFS_TAR_OPTIONS)
+
+define ROOTFS_TAR_CMD
+ tar -c$(TAR_OPTS)f $$@ -C $(TARGET_DIR) .
+endef
+
+$(eval $(call ROOTFS_TARGET,tar))