aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-05-14 23:17:26 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-05-14 23:17:26 -0700
commit2c56f2b65bcf3b3f85db9d2a34501154c9c9404d (patch)
treed9580fb8578f6e1ea0f47dd1e6402ebd41d3a0e9 /rust/Cargo.toml
parente468707ee53f4a8ff75b00a1eec44921672464b6 (diff)
downloadfatcat-2c56f2b65bcf3b3f85db9d2a34501154c9c9404d.tar.gz
fatcat-2c56f2b65bcf3b3f85db9d2a34501154c9c9404d.zip
regenerated and pseudo-integrated
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml13
1 files changed, 10 insertions, 3 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index 94a9a091..f35490e5 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -3,20 +3,27 @@ name = "fatcat"
version = "0.1.0"
authors = ["Bryan Newbold <bnewbold@archive.org>"]
+[workspace]
+members = ["fatcat-api"]
+
[dependencies]
+fatcat-api = {version = "*", path = "fatcat-api"}
diesel = { version = "1.0.0", features = ["postgres"] }
dotenv = "0.9.0"
clap = "*"
+error-chain = "0.11"
# API server
chrono = { version = "0.4", features = ["serde"] }
futures = "0.1"
-hyper = "0.10"
-#hyper-openssl = "0.2"
+hyper = "0.11"
+#hyper-tls = {version = "0.1.2", optional = true}
iron = "0.5"
iron-slog = "*"
iron-test = "*"
-swagger = "0.7"
+swagger = "0.10"
+tokio-core = "0.1.6"
+tokio-proto = "0.1.1"
# TODO
#sentry = "*"