aboutsummaryrefslogtreecommitdiffstats
path: root/rust/Cargo.toml
diff options
context:
space:
mode:
authorBryan Newbold <bnewbold@robocracy.org>2018-05-14 22:01:26 -0700
committerBryan Newbold <bnewbold@robocracy.org>2018-05-14 22:01:35 -0700
commite468707ee53f4a8ff75b00a1eec44921672464b6 (patch)
tree4aa5ba8b5f044eabcbb6d4dffd94502f8e614ea8 /rust/Cargo.toml
parent6ca8ff2abdc3601e3da1f53a5562d96d3af1aac3 (diff)
downloadfatcat-e468707ee53f4a8ff75b00a1eec44921672464b6.tar.gz
fatcat-e468707ee53f4a8ff75b00a1eec44921672464b6.zip
commit older files
Diffstat (limited to 'rust/Cargo.toml')
-rw-r--r--rust/Cargo.toml18
1 files changed, 17 insertions, 1 deletions
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
index c1175b79..94a9a091 100644
--- a/rust/Cargo.toml
+++ b/rust/Cargo.toml
@@ -1,8 +1,24 @@
[package]
-name = "fc"
+name = "fatcat"
version = "0.1.0"
authors = ["Bryan Newbold <bnewbold@archive.org>"]
[dependencies]
diesel = { version = "1.0.0", features = ["postgres"] }
dotenv = "0.9.0"
+clap = "*"
+
+# API server
+chrono = { version = "0.4", features = ["serde"] }
+futures = "0.1"
+hyper = "0.10"
+#hyper-openssl = "0.2"
+iron = "0.5"
+iron-slog = "*"
+iron-test = "*"
+swagger = "0.7"
+
+# TODO
+#sentry = "*"
+#cadence = "*"
+#frank_jwt = "*"