aboutsummaryrefslogtreecommitdiffstats
path: root/guile.init
diff options
context:
space:
mode:
authorThomas Bushnell, BSG <tb@debian.org>2007-12-29 10:18:27 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:39 -0800
commit9429d5ab2c98d17d87c0d9214bc41b37f9419901 (patch)
tree52c431bef6c2fc6bb6b8add16e8d624e3844d8c9 /guile.init
parentd8ae23691ed6392b7f320f5fa7d4dd78ae52c10e (diff)
downloadslib-9429d5ab2c98d17d87c0d9214bc41b37f9419901.tar.gz
slib-9429d5ab2c98d17d87c0d9214bc41b37f9419901.zip
Import Debian changes 3a5-2debian/3a5-2
slib (3a5-2) unstable; urgency=low * debian/rules (binary-indep): init subdir symlink should point to ".", not "..". (Closes: #458172). * debian/preinst: New file. Delete /usr/share/slib/init if it's a directory. * debian/rules (binary-indep): Install preinst into the right place. (Closes: #458181). * guile.init: Use old method of finding implementation-vicinity.
Diffstat (limited to 'guile.init')
-rw-r--r--guile.init12
1 files changed, 6 insertions, 6 deletions
diff --git a/guile.init b/guile.init
index 1ce1bd1..de77645 100644
--- a/guile.init
+++ b/guile.init
@@ -43,13 +43,13 @@
;;; (implementation-vicinity) should be defined to be the pathname of
;;; the directory where any auxillary files to your Scheme
;;; implementation reside.
-;; (define implementation-vicinity
-;; (let* ((path (or (%search-load-path "ice-9/q.scm")
-;; (error "Could not find ice-9/q.scm in " %load-path)))
-;; (vic (substring path 0 (- (string-length path) 11))))
-;; (lambda () vic)))
+(define implementation-vicinity
+ (let* ((path (or (%search-load-path "ice-9/q.scm")
+ (error "Could not find ice-9/q.scm in " %load-path)))
+ (vic (substring path 0 (- (string-length path) 11))))
+ (lambda () vic)))
;;; Rob Browning says %site-dir exists since Guile-1.6
-(define implementation-vicinity %site-dir)
+;;(define implementation-vicinity %site-dir)
;;; (library-vicinity) should be defined to be the pathname of the
;;; directory where files of Scheme library functions reside.