aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--debian/changelog13
-rw-r--r--debian/preinst9
-rwxr-xr-xdebian/rules3
-rw-r--r--guile.init12
4 files changed, 30 insertions, 7 deletions
diff --git a/debian/changelog b/debian/changelog
index e88cc54..dc894b3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,16 @@
+slib (3a5-2) unstable; urgency=low
+
+ * debian/rules (binary-indep): init subdir symlink should point to ".",
+ not "..". (Closes: #458172).
+
+ * debian/preinst: New file. Delete /usr/share/slib/init if it's a directory.
+ * debian/rules (binary-indep): Install preinst into the right place.
+ (Closes: #458181).
+
+ * guile.init: Use old method of finding implementation-vicinity.
+
+ -- Thomas Bushnell, BSG <tb@debian.org> Sat, 29 Dec 2007 10:18:27 -0800
+
slib (3a5-1) unstable; urgency=low
* New upstream release.
diff --git a/debian/preinst b/debian/preinst
new file mode 100644
index 0000000..0c06b42
--- /dev/null
+++ b/debian/preinst
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+set -e
+
+# Older versions of slib stored init files in a separate subdirectory;
+# blow that away so that the symlink can be put in its place.
+if [ "$1" = "upgrade" -a -d /usr/share/slib/init ]; then
+ rm -rf /usr/share/slib/init
+fi
diff --git a/debian/rules b/debian/rules
index 2a147de..dfbb14c 100755
--- a/debian/rules
+++ b/debian/rules
@@ -54,6 +54,7 @@ binary-indep: checkroot build
$(INSTALL_DIR) debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/postinst debian/tmp/DEBIAN
$(INSTALL_PROGRAM) debian/prerm debian/tmp/DEBIAN
+ $(INSTALL_PROGRAM) debian/preinst debian/tmp/DEBIAN
# library
$(INSTALL_DIR) debian/tmp/usr/share/slib
@@ -76,7 +77,7 @@ binary-indep: checkroot build
gzip -9v debian/tmp/usr/share/doc/slib/FAQ
$(INSTALL_DATA) slib/*.html debian/tmp/usr/share/doc/slib
- ln -s .. debian/tmp/usr/share/slib/init
+ ln -s . debian/tmp/usr/share/slib/init
$(INSTALL_DATA) *.init debian/tmp/usr/share/slib
$(INSTALL_DIR) debian/tmp/usr/share/doc-base
diff --git a/guile.init b/guile.init
index 1ce1bd1..de77645 100644
--- a/guile.init
+++ b/guile.init
@@ -43,13 +43,13 @@
;;; (implementation-vicinity) should be defined to be the pathname of
;;; the directory where any auxillary files to your Scheme
;;; implementation reside.
-;; (define implementation-vicinity
-;; (let* ((path (or (%search-load-path "ice-9/q.scm")
-;; (error "Could not find ice-9/q.scm in " %load-path)))
-;; (vic (substring path 0 (- (string-length path) 11))))
-;; (lambda () vic)))
+(define implementation-vicinity
+ (let* ((path (or (%search-load-path "ice-9/q.scm")
+ (error "Could not find ice-9/q.scm in " %load-path)))
+ (vic (substring path 0 (- (string-length path) 11))))
+ (lambda () vic)))
;;; Rob Browning says %site-dir exists since Guile-1.6
-(define implementation-vicinity %site-dir)
+;;(define implementation-vicinity %site-dir)
;;; (library-vicinity) should be defined to be the pathname of the
;;; directory where files of Scheme library functions reside.