aboutsummaryrefslogtreecommitdiffstats
path: root/scm.spec
diff options
context:
space:
mode:
authorSteve Langasek <vorlon@debian.org>2004-12-07 23:23:48 -0800
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:28 -0800
commit37f2f5e0bb11a18deecf48c7ad6bcbf7bd932db2 (patch)
tree692caebb60ec5f80ce528a403b69351ca756d530 /scm.spec
parente21d47d7813159bb71e0671df9b52ec0470c358d (diff)
parentc7d035ae1a729232579a0fe41ed5affa131d3623 (diff)
downloadscm-37f2f5e0bb11a18deecf48c7ad6bcbf7bd932db2.tar.gz
scm-37f2f5e0bb11a18deecf48c7ad6bcbf7bd932db2.zip
Import Debian changes 5d9-4.1debian/5d9-4.1
scm (5d9-4.1) unstable; urgency=high * Non-maintainer upload. * High-urgency upload for sarge-targetted RC bugfix. * Revert upstream "CAUTIOUS" define, which causes the scm build to fail its test suite on alpha (and, it appears, powerpc as well). Closes: #245810. scm (5d9-4) unstable; urgency=low * Apply patch from 144062 to fix hppa build (Closes: #144062) * Change scm.1 section from Jan 4 200 to 1. (lintian) scm (5d9-3) unstable; urgency=low * Properly clean up info files. * Make and install Xlibscm.info. scm (5d9-2) unstable; urgency=low * Fix path problem in slibcat. Hack at mklibcat.scm. (Closes: #241510) scm (5d9-1) unstable; urgency=low * New upstream release * Merge NMU sparc changes (Closes: #191171, #191356) * SHORT_INT is defined for ia64 upstream (Closes: #141928) * Scheme imps now grouped in info file (has been for a while) (Closes: #115452)
Diffstat (limited to 'scm.spec')
-rw-r--r--scm.spec18
1 files changed, 10 insertions, 8 deletions
diff --git a/scm.spec b/scm.spec
index 4be109c..5205315 100644
--- a/scm.spec
+++ b/scm.spec
@@ -1,5 +1,5 @@
%define name scm
-%define version 5d6
+%define version 5d9
%define release 1
%define implpath %{prefix}/lib/scm
# rpm seems to require all on one line, bleah.
@@ -18,7 +18,7 @@ Requires: slib
Summary: SCM Scheme implementation.
Source: ftp://swissnet.ai.mit.edu/pub/scm/scm%{version}.zip
-URL: http://swissnet.ai.mit.edu/~jaffer/SCM.html
+URL: http://swissnet.ai.mit.edu/~jaffer/SCM
BuildRoot: %{_tmppath}/%{name}%{version}
Prefix: /usr
@@ -53,20 +53,21 @@ make clean
export PATH=.:$PATH # to get scmlit in the path.
# Build the executable.
-./build -h system -o udscm5 -l debug -s %{implpath} -F %{features}
+./build -h system -o udscm5 --compiler-options="-O3" -l debug -s %{implpath} -F %{features}
echo "(quit)" | ./udscm5 -no-init-file -r5 -o scm
make check
# Build dlls
make x.so
-./build -h system -F curses -t dll
+./build -h system -F curses -t dll --compiler-options="-O3"
./build -h system -t dll -c sc2.c rgx.c record.c gsubr.c ioext.c posix.c \
- unix.c socket.c ramap.c
-./build -h system -F edit-line -t dll
-./build -h system -F x -t dll
+ unix.c socket.c ramap.c --compiler-options="-O3"
+./build -h system -F edit-line -t dll --compiler-options="-O3"
+./build -h system -F x -t dll --compiler-options="-O3"
# Build libscm.a static library
-./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib
+./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib \
+ --compiler-options="-O3"
%install
mkdir -p ${RPM_BUILD_ROOT}%{prefix}/bin
@@ -143,6 +144,7 @@ rm -f %{prefix}/bin/scm
%{prefix}/lib/scm/hobbit.scm
%{prefix}/lib/scm/scmhob.scm
%{prefix}/lib/scm/scmhob.h
+%{prefix}/lib/scm/patchlvl.h
%{prefix}/lib/scm/build.scm
%{prefix}/lib/scm/build
%{prefix}/lib/scm/Iedline.scm