aboutsummaryrefslogtreecommitdiffstats
path: root/scm.spec
diff options
context:
space:
mode:
authorLaMont Jones <lamont@debian.org>2003-05-07 08:36:40 -0600
committerBryan Newbold <bnewbold@robocracy.org>2017-02-20 00:05:27 -0800
commite21d47d7813159bb71e0671df9b52ec0470c358d (patch)
tree3c7770ea846123c291f599044e9f234ac17616bb /scm.spec
parent8cfce36c6a4fc2e0a0ab6ef2db66a23cbe462693 (diff)
parentdeda2c0fd8689349fea2a900199a76ff7ecb319e (diff)
downloadscm-e21d47d7813159bb71e0671df9b52ec0470c358d.tar.gz
scm-e21d47d7813159bb71e0671df9b52ec0470c358d.zip
Import Debian changes 5d6-3.2debian/5d6-3.2
scm (5d6-3.2) unstable; urgency=low * Fix hppa compile. Closes: #144062 scm (5d6-3.1) unstable; urgency=low * NMU with patch from James Troup, to fix FTBFS on sparc. Closes: #191171 scm (5d6-3) unstable; urgency=low * Add build depend on xlibs-dev (Closes: #148020) scm (5d6-2) unstable; urgency=low * Remove libregexx-dev from build-depends. * Change build to use ./scmlit rather than scmlit (should fix some build problems) (looks like alpha is mostly building) * New release (Closes: #140175) * Built with turtlegraphics last time (Closes: #58515) scm (5d6-1) unstable; urgency=low * New upstream. * Add xlib and turtlegr to requested list of features. (closes some bug) * Make clean actually clean most everything up. * Remove hacks renaming build to something else and just set build as a .PHONY target in debian/rules. * Add the turtlegr code. scm (5d5-1) unstable; urgency=low * New upstream * Has fixes for 64 bit archs. May fix alpha compile problem. Does fix (Closes: #140175) * Take out -O2 arg. scm (5d4-3) unstable; urgency=low * Don't link with regexx, but just use libc6's regular expression functions. * Define (terms) to output /usr/share/common-licenses/GPL (Closes: #119321) scm (5d4-2) unstable; urgency=low * Add texinfo to build depends (Closes: #107011) scm (5d4-1) unstable; urgency=low * New upstream release. * Move install-info --remove to prerm. scm (5d3-5) unstable; urgency=low * Move scm info files to section "The Algorithmic Language Scheme" to match up with guile. scm (5d3-4) unstable; urgency=low * Fix build depends (Closes: #76691) scm (5d3-3) unstable; urgency=low * Fix path in scm dhelp file. scm (5d3-2) unstable; urgency=low * Actually put the header files in the package. Oops. scm (5d3-1) unstable; urgency=low * New upstream. (Closes: #74761) * Make (terms) use new license location. * Make use libregexx rather than librx. * Fix build depends for above. * Using new regex lib seems to fix crash (Closes: #66787) * Consider adding scm-dev package with headers, but instead just add the headers to the scm package. (Closes: #70787) * Add doc-base support.
Diffstat (limited to 'scm.spec')
-rw-r--r--scm.spec168
1 files changed, 168 insertions, 0 deletions
diff --git a/scm.spec b/scm.spec
new file mode 100644
index 0000000..4be109c
--- /dev/null
+++ b/scm.spec
@@ -0,0 +1,168 @@
+%define name scm
+%define version 5d6
+%define release 1
+%define implpath %{prefix}/lib/scm
+# rpm seems to require all on one line, bleah.
+%define features cautious bignums arrays inexact dump dynamic-linking macro engineering-notation
+
+Name: %{name}
+Release: %{release}
+Version: %{version}
+Packager: Radey Shouman <shouman@ne.mediaone.net>
+
+Copyright: GPL
+Vendor: Aubrey Jaffer <agj @ alum.mit.edu>
+Group: Development/Languages
+Provides: scm
+Requires: slib
+
+Summary: SCM Scheme implementation.
+Source: ftp://swissnet.ai.mit.edu/pub/scm/scm%{version}.zip
+URL: http://swissnet.ai.mit.edu/~jaffer/SCM.html
+BuildRoot: %{_tmppath}/%{name}%{version}
+Prefix: /usr
+
+%description
+Scm conforms to Revised^5 Report on the Algorithmic Language Scheme and
+the IEEE P1178 specification. Scm provides a machine independent
+platform for JACAL, a symbolic algebra system.
+
+This distribution requires libdl.so from the glibc-devel package and the
+slib Scheme library package. If your machine lacks XFree86 or readline,
+install with --nodeps.
+
+%define __os_install_post /usr/lib/rpm/brp-compress
+
+%prep
+rm -rf /var/tmp/%{name}%{version}
+%setup -n scm -c -T
+cd ..
+unzip $RPM_SOURCE_DIR/scm%{version}.zip
+
+%build
+# SLIB is required to build SCM.
+if [ -n "$SCHEME_LIBRARY_PATH" ]; then
+ echo using SLIB $SCHEME_LIBRARY_PATH
+elif [ -d /usr/share/slib ]; then
+ export SCHEME_LIBRARY_PATH=/usr/share/slib/
+elif [ -d /usr/lib/slib ]; then
+ export SCHEME_LIBRARY_PATH=/usr/lib/slib/
+fi
+make scmlit
+make clean
+export PATH=.:$PATH # to get scmlit in the path.
+
+# Build the executable.
+./build -h system -o udscm5 -l debug -s %{implpath} -F %{features}
+echo "(quit)" | ./udscm5 -no-init-file -r5 -o scm
+make check
+
+# Build dlls
+make x.so
+./build -h system -F curses -t dll
+./build -h system -t dll -c sc2.c rgx.c record.c gsubr.c ioext.c posix.c \
+ unix.c socket.c ramap.c
+./build -h system -F edit-line -t dll
+./build -h system -F x -t dll
+
+# Build libscm.a static library
+./build -h system -F cautious bignums arrays inexact dynamic-linking -t lib
+
+%install
+mkdir -p ${RPM_BUILD_ROOT}%{prefix}/bin
+mkdir -p ${RPM_BUILD_ROOT}%{prefix}/lib/scm
+mkdir -p ${RPM_BUILD_ROOT}%{prefix}/man/man1
+make prefix=${RPM_BUILD_ROOT}%{prefix}/ install
+make prefix=${RPM_BUILD_ROOT}%{prefix}/ installlib
+rm -f ${RPM_BUILD_ROOT}%{prefix}/bin/scm
+cp udscm5 ${RPM_BUILD_ROOT}%{prefix}/bin/
+
+# Assume SLIB is in /usr/share/slib, as installed by the slib rpm.
+cat > ${RPM_BUILD_ROOT}%{prefix}/lib/scm/require.scm <<EOF
+(set! library-vicinity (lambda () "%{prefix}/share/slib/"))
+EOF
+
+mkdir -p ${RPM_BUILD_ROOT}%{prefix}/info/
+gzip *.info
+cp *.info.gz ${RPM_BUILD_ROOT}%{prefix}/info/
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+/sbin/install-info /usr/info/scm.info.gz /usr/info/dir
+/sbin/install-info /usr/info/hobbit.info.gz /usr/info/dir
+/sbin/install-info /usr/info/Xlibscm.info.gz /usr/info/dir
+echo "(quit)" | %{prefix}/bin/udscm5 -no-init-file -r5 -o %{prefix}/bin/scm
+ln -s %{prefix}/bin/scm /usr/local/bin/scm
+ln -s %{prefix}/lib/scm /usr/local/lib/
+/usr/bin/scm -c "(require 'new-catalog)"
+
+%verifyscript
+cp -f %{prefix}/lib/scm/r4rstest.scm /tmp/
+(cd /tmp
+ %{prefix}/bin/scm -fr4rstest.scm -e'(test-sc4)(test-cont)(test-delay)(gc)')
+
+%preun
+rm -f %{prefix}/lib/scm/slibcat %{prefix}/lib/scm/implcat
+if [ -L /usr/local/bin/scm ] && \
+ ls -l /usr/local/bin/scm | grep -q "> %{prefix}/bin/scm"; then
+ rm -f /usr/local/bin/scm
+fi
+if [ -L /usr/local/lib/scm ] && \
+ ls -l /usr/local/lib/scm | grep -q "> %{prefix}/lib/scm"; then
+ rm -f /usr/local/lib/scm
+fi
+rm -f %{prefix}/bin/scm
+
+%files
+%defattr(-, root, root)
+%{prefix}/bin/scmlit
+%{prefix}/bin/udscm5
+%dir %{prefix}/lib/scm
+# No wildcards here because we need to segregate files by package.
+%{prefix}/lib/scm/crs.so
+%{prefix}/lib/scm/gsubr.so
+%{prefix}/lib/scm/posix.so
+%{prefix}/lib/scm/record.so
+%{prefix}/lib/scm/sc2.so
+%{prefix}/lib/scm/unix.so
+%{prefix}/lib/scm/ioext.so
+%{prefix}/lib/scm/ramap.so
+%{prefix}/lib/scm/socket.so
+%{prefix}/lib/scm/rgx.so
+%{prefix}/lib/scm/Init%{version}.scm
+%{prefix}/lib/scm/require.scm
+%{prefix}/lib/scm/Macexp.scm
+%{prefix}/lib/scm/Macro.scm
+%{prefix}/lib/scm/Tscript.scm
+%{prefix}/lib/scm/Transcen.scm
+%{prefix}/lib/scm/mkimpcat.scm
+%{prefix}/lib/scm/Link.scm
+%{prefix}/lib/scm/compile.scm
+%{prefix}/lib/scm/hobbit.scm
+%{prefix}/lib/scm/scmhob.scm
+%{prefix}/lib/scm/scmhob.h
+%{prefix}/lib/scm/build.scm
+%{prefix}/lib/scm/build
+%{prefix}/lib/scm/Iedline.scm
+%{prefix}/lib/scm/edline.so
+%{prefix}/lib/scm/x.so
+%{prefix}/lib/scm/xevent.scm
+%{prefix}/lib/scm/xatoms.scm
+%{prefix}/lib/scm/x11.scm
+%{prefix}/lib/scm/keysymdef.scm
+%{prefix}/lib/scm/r4rstest.scm
+/usr/info/Xlibscm.info.gz
+/usr/info/hobbit.info.gz
+/usr/info/scm.info.gz
+/usr/man/man1/scm.1.gz
+
+%{prefix}/lib/libscm.a
+%{prefix}/include/scm.h
+%{prefix}/include/scmfig.h
+%{prefix}/include/scmflags.h
+
+%doc ANNOUNCE COPYING QUICKREF README ChangeLog
+
+%changelog