summaryrefslogtreecommitdiffstats
path: root/package/xz
diff options
context:
space:
mode:
Diffstat (limited to 'package/xz')
-rw-r--r--package/xz/Config.in14
-rw-r--r--package/xz/xz.mk13
2 files changed, 27 insertions, 0 deletions
diff --git a/package/xz/Config.in b/package/xz/Config.in
new file mode 100644
index 000000000..50116f299
--- /dev/null
+++ b/package/xz/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_XZ
+ bool "xz-utils"
+ help
+ XZ is the successor to the Lempel-Ziv/Markov-chain Algorithm
+ compression format, which provides memory-hungry but powerful
+ compression (often better than bzip2) and fast, easy decompression.
+
+ This package provides the command line tools for working with XZ
+ compression, including xz, unxz, xzcat, xzgrep, and so on. They can
+ also handle the older LZMA format, and if invoked via appropriate
+ symlinks will emulate the behavior of the commands in the lzma
+ package.
+
+ http://tukaani.org/xz/
diff --git a/package/xz/xz.mk b/package/xz/xz.mk
new file mode 100644
index 000000000..7490f7708
--- /dev/null
+++ b/package/xz/xz.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# xz-utils
+#
+#############################################################
+XZ_VERSION = 4.999.9beta
+XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
+XZ_SITE = http://tukaani.org/xz/
+XZ_INSTALL_STAGING = YES
+XZ_LIBTOOL_PATCH = NO
+
+$(eval $(call AUTOTARGETS,package,xz))
+$(eval $(call AUTOTARGETS,package,xz,host))