summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--CHANGES2
-rw-r--r--package/Config.in1
-rw-r--r--package/xz/Config.in14
-rw-r--r--package/xz/xz.mk13
4 files changed, 30 insertions, 0 deletions
diff --git a/CHANGES b/CHANGES
index 7ae67d946..1127f89e7 100644
--- a/CHANGES
+++ b/CHANGES
@@ -15,6 +15,8 @@
Download handling reworked and support for git/svn downloads
added.
+ New packages: xz
+
Updated/fixed packages: alsa-lib, at, avahi, berkeleydb, bind,
bmon, bridge-utils, busybox, dbus, dmraid, docker, dropbear,
e2fsprogs, expat, freetype, gawk, gvfs, haserl, hostapd,
diff --git a/package/Config.in b/package/Config.in
index f9a040555..ce6057b97 100644
--- a/package/Config.in
+++ b/package/Config.in
@@ -13,6 +13,7 @@ source "package/gzip/Config.in"
endif
source "package/lzop/Config.in"
source "package/lzma/Config.in"
+source "package/xz/Config.in"
endmenu
menu "Debugging, profiling and benchmark"
diff --git a/package/xz/Config.in b/package/xz/Config.in
new file mode 100644
index 000000000..50116f299
--- /dev/null
+++ b/package/xz/Config.in
@@ -0,0 +1,14 @@
+config BR2_PACKAGE_XZ
+ bool "xz-utils"
+ help
+ XZ is the successor to the Lempel-Ziv/Markov-chain Algorithm
+ compression format, which provides memory-hungry but powerful
+ compression (often better than bzip2) and fast, easy decompression.
+
+ This package provides the command line tools for working with XZ
+ compression, including xz, unxz, xzcat, xzgrep, and so on. They can
+ also handle the older LZMA format, and if invoked via appropriate
+ symlinks will emulate the behavior of the commands in the lzma
+ package.
+
+ http://tukaani.org/xz/
diff --git a/package/xz/xz.mk b/package/xz/xz.mk
new file mode 100644
index 000000000..7490f7708
--- /dev/null
+++ b/package/xz/xz.mk
@@ -0,0 +1,13 @@
+#############################################################
+#
+# xz-utils
+#
+#############################################################
+XZ_VERSION = 4.999.9beta
+XZ_SOURCE = xz-$(XZ_VERSION).tar.bz2
+XZ_SITE = http://tukaani.org/xz/
+XZ_INSTALL_STAGING = YES
+XZ_LIBTOOL_PATCH = NO
+
+$(eval $(call AUTOTARGETS,package,xz))
+$(eval $(call AUTOTARGETS,package,xz,host))