summaryrefslogtreecommitdiffstats
path: root/package/webp
diff options
context:
space:
mode:
Diffstat (limited to 'package/webp')
-rw-r--r--package/webp/Config.in7
-rw-r--r--package/webp/webp.mk30
2 files changed, 37 insertions, 0 deletions
diff --git a/package/webp/Config.in b/package/webp/Config.in
new file mode 100644
index 000000000..e385b5ee4
--- /dev/null
+++ b/package/webp/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_WEBP
+ bool "webp"
+ help
+ WebP is a new image format that provides lossless and lossy
+ compression for images on the web
+
+ https://developers.google.com/speed/webp/
diff --git a/package/webp/webp.mk b/package/webp/webp.mk
new file mode 100644
index 000000000..0099c3c5d
--- /dev/null
+++ b/package/webp/webp.mk
@@ -0,0 +1,30 @@
+#####################################################################
+#
+# webp
+#
+#####################################################################
+
+WEBP_VERSION = 0.2.1
+WEBP_SOURCE = libwebp-$(WEBP_VERSION).tar.gz
+WEBP_SITE = https://webp.googlecode.com/files
+WEBP_LICENSE = BSD-3c
+WEBP_LICENSE_FILES = COPYING
+WEBP_INSTALL_STAGING = YES
+
+WEBP_CONF_OPT += \
+ --with-jpegincludedir=$(STAGING_DIR)/usr/include \
+ --with-jpeglibdir=$(STAGING_DIR)/usr/lib \
+ --with-tiffincludedir=$(STAGING_DIR)/usr/include \
+ --with-tifflibdir=$(STAGING_DIR)/usr/lib
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+WEBP_DEPENDENCIES += libpng
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
+else
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=/bin/false
+endif
+
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_TIFF),tiff)
+
+$(eval $(autotools-package))