summaryrefslogtreecommitdiffstats
path: root/package/webp
diff options
context:
space:
mode:
authorgilles.talis@gmail.com <gilles.talis@gmail.com>2013-01-24 18:35:53 +0000
committerPeter Korsgaard <jacmet@sunsite.dk>2013-05-05 22:38:11 +0200
commit4d91863709c8667fe511b6ca2267787bcfa2911c (patch)
treed30bfa984e8148942f0680ae7dda333b59a62d9a /package/webp
parentee9e3af06f038d573f6fe2a0d3fa8a88d0962138 (diff)
downloadbuildroot-novena-4d91863709c8667fe511b6ca2267787bcfa2911c.tar.gz
buildroot-novena-4d91863709c8667fe511b6ca2267787bcfa2911c.zip
webp: new package
[Peter: fix white space errors] Signed-off-by: Gilles Talis <gilles.talis@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/webp')
-rw-r--r--package/webp/Config.in7
-rw-r--r--package/webp/webp.mk30
2 files changed, 37 insertions, 0 deletions
diff --git a/package/webp/Config.in b/package/webp/Config.in
new file mode 100644
index 000000000..e385b5ee4
--- /dev/null
+++ b/package/webp/Config.in
@@ -0,0 +1,7 @@
+config BR2_PACKAGE_WEBP
+ bool "webp"
+ help
+ WebP is a new image format that provides lossless and lossy
+ compression for images on the web
+
+ https://developers.google.com/speed/webp/
diff --git a/package/webp/webp.mk b/package/webp/webp.mk
new file mode 100644
index 000000000..0099c3c5d
--- /dev/null
+++ b/package/webp/webp.mk
@@ -0,0 +1,30 @@
+#####################################################################
+#
+# webp
+#
+#####################################################################
+
+WEBP_VERSION = 0.2.1
+WEBP_SOURCE = libwebp-$(WEBP_VERSION).tar.gz
+WEBP_SITE = https://webp.googlecode.com/files
+WEBP_LICENSE = BSD-3c
+WEBP_LICENSE_FILES = COPYING
+WEBP_INSTALL_STAGING = YES
+
+WEBP_CONF_OPT += \
+ --with-jpegincludedir=$(STAGING_DIR)/usr/include \
+ --with-jpeglibdir=$(STAGING_DIR)/usr/lib \
+ --with-tiffincludedir=$(STAGING_DIR)/usr/include \
+ --with-tifflibdir=$(STAGING_DIR)/usr/lib
+
+ifeq ($(BR2_PACKAGE_LIBPNG),y)
+WEBP_DEPENDENCIES += libpng
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
+else
+WEBP_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=/bin/false
+endif
+
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_JPEG),jpeg)
+WEBP_DEPENDENCIES += $(if $(BR2_PACKAGE_TIFF),tiff)
+
+$(eval $(autotools-package))