summaryrefslogtreecommitdiffstats
path: root/package/oprofile
diff options
context:
space:
mode:
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/oprofile.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 5da794bad..fc2192843 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -30,7 +30,10 @@ OPROFILE_DEPENDENCIES = popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
- cp -dpfr $(@D)/events/$(OPROFILE_ARCH) $(TARGET_DIR)/usr/share/oprofile
+ if [ -d $(@D)/events/$(OPROFILE_ARCH) ]; then \
+ cp -dpfr $(@D)/events/$(OPROFILE_ARCH) \
+ $(TARGET_DIR)/usr/share/oprofile; \
+ fi
$(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
$(INSTALL) -m 755 $(@D)/utils/opcontrol $(TARGET_DIR)/usr/bin
$(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin