summaryrefslogtreecommitdiffstats
path: root/package/oprofile
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2012-05-22 10:11:47 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2012-05-22 10:11:47 +0200
commitc73df193c558dfcf8386082548d8bea396960f39 (patch)
treebbecc5da9234035928c9446a29844dfb447a2c98 /package/oprofile
parent602de0675ef334de9f77a670561f2b1887550305 (diff)
downloadbuildroot-novena-c73df193c558dfcf8386082548d8bea396960f39.tar.gz
buildroot-novena-c73df193c558dfcf8386082548d8bea396960f39.zip
oprofile: fix target-install for archs without performance counters support
These archs can still use the timer mode. Fixes http://autobuild.buildroot.org/results/2627ee17e1f1a58520e01c52af365998f648bbc5/ Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/oprofile')
-rw-r--r--package/oprofile/oprofile.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/package/oprofile/oprofile.mk b/package/oprofile/oprofile.mk
index 5da794bad..fc2192843 100644
--- a/package/oprofile/oprofile.mk
+++ b/package/oprofile/oprofile.mk
@@ -30,7 +30,10 @@ OPROFILE_DEPENDENCIES = popt binutils
define OPROFILE_INSTALL_TARGET_CMDS
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/bin
$(INSTALL) -d -m 755 $(TARGET_DIR)/usr/share/oprofile
- cp -dpfr $(@D)/events/$(OPROFILE_ARCH) $(TARGET_DIR)/usr/share/oprofile
+ if [ -d $(@D)/events/$(OPROFILE_ARCH) ]; then \
+ cp -dpfr $(@D)/events/$(OPROFILE_ARCH) \
+ $(TARGET_DIR)/usr/share/oprofile; \
+ fi
$(INSTALL) -m 644 $(@D)/libregex/stl.pat $(TARGET_DIR)/usr/share/oprofile
$(INSTALL) -m 755 $(@D)/utils/opcontrol $(TARGET_DIR)/usr/bin
$(INSTALL) -m 755 $(addprefix $(@D)/, $(OPROFILE_BINARIES)) $(TARGET_DIR)/usr/bin