summaryrefslogtreecommitdiffstats
path: root/package/netsnmp
diff options
context:
space:
mode:
Diffstat (limited to 'package/netsnmp')
-rw-r--r--package/netsnmp/Config.in8
-rw-r--r--package/netsnmp/netsnmp.mk5
2 files changed, 13 insertions, 0 deletions
diff --git a/package/netsnmp/Config.in b/package/netsnmp/Config.in
index 5a3e9aabc..431be2d38 100644
--- a/package/netsnmp/Config.in
+++ b/package/netsnmp/Config.in
@@ -6,3 +6,11 @@ config BR2_PACKAGE_NETSNMP
http://net-snmp.sourceforge.net/
+config BR2_PACKAGE_NETSNMP_ENABLE_MIBS
+ bool "Install MIB files on target and enable MIB loading code"
+ default y
+ depends on BR2_PACKAGE_NETSNMP
+ help
+ The net-snmp package contains a selection of MIB files.
+ Say yes if you want those MIB files installed on the target
+ and enable the code that parses the MIB files.
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index a44f3feef..05d8db74f 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -43,6 +43,11 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
NETSNMP_CONF_OPT += --disable-manuals
endif
+ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_MIBS),y)
+ NETSNMP_CONF_OPT += --disable-mib-loading
+ NETSNMP_CONF_OPT += --disable-mibs
+endif
+
# Remove IPv6 MIBs if there's no IPv6
ifneq ($(BR2_INET_IPV6),y)
define NETSNMP_REMOVE_MIBS_IPV6