summaryrefslogtreecommitdiffstats
path: root/package/netsnmp/netsnmp.mk
diff options
context:
space:
mode:
Diffstat (limited to 'package/netsnmp/netsnmp.mk')
-rw-r--r--package/netsnmp/netsnmp.mk5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/netsnmp/netsnmp.mk b/package/netsnmp/netsnmp.mk
index a44f3feef..05d8db74f 100644
--- a/package/netsnmp/netsnmp.mk
+++ b/package/netsnmp/netsnmp.mk
@@ -43,6 +43,11 @@ ifneq ($(BR2_HAVE_DOCUMENTATION),y)
NETSNMP_CONF_OPT += --disable-manuals
endif
+ifneq ($(BR2_PACKAGE_NETSNMP_ENABLE_MIBS),y)
+ NETSNMP_CONF_OPT += --disable-mib-loading
+ NETSNMP_CONF_OPT += --disable-mibs
+endif
+
# Remove IPv6 MIBs if there's no IPv6
ifneq ($(BR2_INET_IPV6),y)
define NETSNMP_REMOVE_MIBS_IPV6