summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mpg123
diff options
context:
space:
mode:
Diffstat (limited to 'package/multimedia/mpg123')
-rw-r--r--package/multimedia/mpg123/mpg123.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/multimedia/mpg123/mpg123.mk b/package/multimedia/mpg123/mpg123.mk
index c01c8adb4..8ea05a88f 100644
--- a/package/multimedia/mpg123/mpg123.mk
+++ b/package/multimedia/mpg123/mpg123.mk
@@ -57,4 +57,11 @@ endif
MPG123_CONF_OPT += --with-audio=$(shell echo $(MPG123_AUDIO) | tr ' ' ,)
+ifeq ($(BR2_PACKAGE_LIBTOOL),y)
+MPG123_DEPENDENCIES += libtool
+# .la files gets stripped unless HAVE_DEVFILES is enabled, so directly
+# load .so files rather than .la
+MPG123_CONF_OPT += --with-modules --with-module-suffix=.so
+endif
+
$(eval $(call AUTOTARGETS))