summaryrefslogtreecommitdiffstats
path: root/package/multimedia/mpg123
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2011-10-20 16:07:46 +0200
committerPeter Korsgaard <jacmet@sunsite.dk>2011-10-20 16:10:10 +0200
commit6206828e3f39721fc0a567818d967236b1afc97c (patch)
treeba91cc121d81a59d44a0e38a309be12c2a3345b9 /package/multimedia/mpg123
parent6161049aeda617a3ed93253c1b0122aecf90d4c7 (diff)
downloadbuildroot-novena-6206828e3f39721fc0a567818d967236b1afc97c.tar.gz
buildroot-novena-6206828e3f39721fc0a567818d967236b1afc97c.zip
mpg123: fix module loading with libtool / !HAVE_DEVFILES
mpg123 enables loadable modules support if libtool is detected, but by default tries to load <module>.la, which we strip from the rootfs unless HAVE_DEVFILES is enabled. Fix it by directly loading .so files instead. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/multimedia/mpg123')
-rw-r--r--package/multimedia/mpg123/mpg123.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/multimedia/mpg123/mpg123.mk b/package/multimedia/mpg123/mpg123.mk
index c01c8adb4..8ea05a88f 100644
--- a/package/multimedia/mpg123/mpg123.mk
+++ b/package/multimedia/mpg123/mpg123.mk
@@ -57,4 +57,11 @@ endif
MPG123_CONF_OPT += --with-audio=$(shell echo $(MPG123_AUDIO) | tr ' ' ,)
+ifeq ($(BR2_PACKAGE_LIBTOOL),y)
+MPG123_DEPENDENCIES += libtool
+# .la files gets stripped unless HAVE_DEVFILES is enabled, so directly
+# load .so files rather than .la
+MPG123_CONF_OPT += --with-modules --with-module-suffix=.so
+endif
+
$(eval $(call AUTOTARGETS))