summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch25
-rw-r--r--package/libcurl/libcurl.mk3
2 files changed, 2 insertions, 26 deletions
diff --git a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch b/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
deleted file mode 100644
index b15ed9631..000000000
--- a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-ssluse.c: fix build breakage with --with-ssl --disable-verbose
-
-Revision 1.206 of ssluse.c removed the prefix argument to asn1_output,
-but it is still referenced in the CURL_DISABLE_VERBOSE_STRINGS case.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- lib/ssluse.c | 4 ----
- 1 file changed, 4 deletions(-)
-
-Index: curl-7.19.2/lib/ssluse.c
-===================================================================
---- curl-7.19.2.orig/lib/ssluse.c
-+++ curl-7.19.2/lib/ssluse.c
-@@ -923,10 +923,6 @@
- int i;
- int year=0,month=0,day=0,hour=0,minute=0,second=0;
-
--#ifdef CURL_DISABLE_VERBOSE_STRINGS
-- (void)prefix;
--#endif
--
- i=tm->length;
- asn1_string=(const char *)tm->data;
-
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 863c30144..488df0455 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -3,11 +3,12 @@
# libcurl
#
#############################################################
-LIBCURL_VERSION = 7.19.2
+LIBCURL_VERSION = 7.21.0
LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
LIBCURL_SITE = http://curl.haxx.se/download/
LIBCURL_INSTALL_STAGING = YES
LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols
+LIBCURL_LIBTOOL_PATCH = NO
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBCURL_DEPENDENCIES += openssl