summaryrefslogtreecommitdiffstats
path: root/package/libcurl
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 18:16:49 +0200
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-07-29 22:18:58 +0200
commit28ac3c6785961411af29a9d22388697610b55667 (patch)
tree953336d6b83443e05ab7e87b28ae9be9e297d7a1 /package/libcurl
parent60f945e47a15e10f0e777f69b05492b6f7ba918d (diff)
downloadbuildroot-novena-28ac3c6785961411af29a9d22388697610b55667.tar.gz
buildroot-novena-28ac3c6785961411af29a9d22388697610b55667.zip
libcurl: bump version to fix build issue
The ./configure script of libcurl includes <arpa_inet.h> instead of <arpa/inet.h> when testing for inet_pton(). The test fails, but it doesn't prevent libcurl to build as it can work without inet_pton(). However, it fills the configure cache with the fact that inet_pton() does not exist. And later, tcpreplay reads this from the configure cache and fails to build, because tcpreplay really need inet_pton(). Unfortunately, just fixing the .m4 file doesn't work because the autoreconfiguration of the package fails. Since the fix for this problem is already upstream, the easiest solution is therefore to bump libcurl. The libcurl-7.19.2-fix-ssl-no-verbose.patch patch is no longer needed. Since we're patching a m4 file, we must autoreconfigure the package. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/libcurl')
-rw-r--r--package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch25
-rw-r--r--package/libcurl/libcurl.mk3
2 files changed, 2 insertions, 26 deletions
diff --git a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch b/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
deleted file mode 100644
index b15ed9631..000000000
--- a/package/libcurl/libcurl-7.19.2-fix-ssl-no-verbose.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-ssluse.c: fix build breakage with --with-ssl --disable-verbose
-
-Revision 1.206 of ssluse.c removed the prefix argument to asn1_output,
-but it is still referenced in the CURL_DISABLE_VERBOSE_STRINGS case.
-
-Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
----
- lib/ssluse.c | 4 ----
- 1 file changed, 4 deletions(-)
-
-Index: curl-7.19.2/lib/ssluse.c
-===================================================================
---- curl-7.19.2.orig/lib/ssluse.c
-+++ curl-7.19.2/lib/ssluse.c
-@@ -923,10 +923,6 @@
- int i;
- int year=0,month=0,day=0,hour=0,minute=0,second=0;
-
--#ifdef CURL_DISABLE_VERBOSE_STRINGS
-- (void)prefix;
--#endif
--
- i=tm->length;
- asn1_string=(const char *)tm->data;
-
diff --git a/package/libcurl/libcurl.mk b/package/libcurl/libcurl.mk
index 863c30144..488df0455 100644
--- a/package/libcurl/libcurl.mk
+++ b/package/libcurl/libcurl.mk
@@ -3,11 +3,12 @@
# libcurl
#
#############################################################
-LIBCURL_VERSION = 7.19.2
+LIBCURL_VERSION = 7.21.0
LIBCURL_SOURCE = curl-$(LIBCURL_VERSION).tar.bz2
LIBCURL_SITE = http://curl.haxx.se/download/
LIBCURL_INSTALL_STAGING = YES
LIBCURL_CONF_OPT = --disable-verbose --disable-manual --enable-hidden-symbols
+LIBCURL_LIBTOOL_PATCH = NO
ifeq ($(BR2_PACKAGE_OPENSSL),y)
LIBCURL_DEPENDENCIES += openssl