summaryrefslogtreecommitdiffstats
path: root/package/gzip
diff options
context:
space:
mode:
Diffstat (limited to 'package/gzip')
-rw-r--r--package/gzip/Config.in2
-rw-r--r--package/gzip/gzip.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/gzip/Config.in b/package/gzip/Config.in
index e80789454..45e4f65d1 100644
--- a/package/gzip/Config.in
+++ b/package/gzip/Config.in
@@ -3,6 +3,6 @@ config BR2_PACKAGE_GZIP
default n
help
Standard GNU compressor. Provides things like gzip,
- gunzip, gzcat, etc...
+ gunzip, g$(ZCAT), etc...
http://www.gnu.org/software/gzip/gzip.html
diff --git a/package/gzip/gzip.mk b/package/gzip/gzip.mk
index 542190cc4..1c420e401 100644
--- a/package/gzip/gzip.mk
+++ b/package/gzip/gzip.mk
@@ -8,7 +8,7 @@ GZIP_SOURCE:=gzip-$(GZIP_VER).tar.gz
#GZIP_SITE:=ftp://alpha.gnu.org/gnu/gzip
GZIP_SITE:=http://mirrors.ircam.fr/pub/gnu/alpha/gnu/gzip
GZIP_DIR:=$(BUILD_DIR)/gzip-$(GZIP_VER)
-GZIP_CAT:=zcat
+GZIP_CAT:=$(ZCAT)
GZIP_BINARY:=$(GZIP_DIR)/gzip
GZIP_TARGET_BINARY:=$(TARGET_DIR)/bin/zmore
@@ -57,7 +57,7 @@ $(GZIP_TARGET_BINARY): $(GZIP_BINARY)
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
(cd $(TARGET_DIR)/bin; \
ln -snf gzip gunzip; \
- ln -snf gzip zcat; \
+ ln -snf gzip $(ZCAT); \
ln -snf zdiff zcmp; \
ln -snf zgrep zegrep; \
ln -snf zgrep zfgrep;)