summaryrefslogtreecommitdiffstats
path: root/package/gzip
diff options
context:
space:
mode:
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-10-01 15:17:52 +0000
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>2006-10-01 15:17:52 +0000
commit6342c83201d5fd2acef0f3193f53b19f74b14c73 (patch)
tree8653e11ddecfde69a6545825d0cc5058e0906e9c /package/gzip
parent859b9137fd6cfb62380691271aec4b06f086f900 (diff)
downloadbuildroot-novena-6342c83201d5fd2acef0f3193f53b19f74b14c73.tar.gz
buildroot-novena-6342c83201d5fd2acef0f3193f53b19f74b14c73.zip
- use $(ZCAT) as configured by the user instead of hardcoded 'zcat' that may not exist; Closes #971
Silly, unchecked sed -i -e "/[^b]zcat/s/zcat/\$\(ZCAT\)/g" $(svngrep "[^b]zcat" * -rl | grep -v Config.in)
Diffstat (limited to 'package/gzip')
-rw-r--r--package/gzip/Config.in2
-rw-r--r--package/gzip/gzip.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/gzip/Config.in b/package/gzip/Config.in
index e80789454..45e4f65d1 100644
--- a/package/gzip/Config.in
+++ b/package/gzip/Config.in
@@ -3,6 +3,6 @@ config BR2_PACKAGE_GZIP
default n
help
Standard GNU compressor. Provides things like gzip,
- gunzip, gzcat, etc...
+ gunzip, g$(ZCAT), etc...
http://www.gnu.org/software/gzip/gzip.html
diff --git a/package/gzip/gzip.mk b/package/gzip/gzip.mk
index 542190cc4..1c420e401 100644
--- a/package/gzip/gzip.mk
+++ b/package/gzip/gzip.mk
@@ -8,7 +8,7 @@ GZIP_SOURCE:=gzip-$(GZIP_VER).tar.gz
#GZIP_SITE:=ftp://alpha.gnu.org/gnu/gzip
GZIP_SITE:=http://mirrors.ircam.fr/pub/gnu/alpha/gnu/gzip
GZIP_DIR:=$(BUILD_DIR)/gzip-$(GZIP_VER)
-GZIP_CAT:=zcat
+GZIP_CAT:=$(ZCAT)
GZIP_BINARY:=$(GZIP_DIR)/gzip
GZIP_TARGET_BINARY:=$(TARGET_DIR)/bin/zmore
@@ -57,7 +57,7 @@ $(GZIP_TARGET_BINARY): $(GZIP_BINARY)
$(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
(cd $(TARGET_DIR)/bin; \
ln -snf gzip gunzip; \
- ln -snf gzip zcat; \
+ ln -snf gzip $(ZCAT); \
ln -snf zdiff zcmp; \
ln -snf zgrep zegrep; \
ln -snf zgrep zfgrep;)