summaryrefslogtreecommitdiffstats
path: root/package/coreutils
diff options
context:
space:
mode:
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils-7.4-rename-m4-fix.patch19
-rw-r--r--package/coreutils/coreutils.mk3
2 files changed, 22 insertions, 0 deletions
diff --git a/package/coreutils/coreutils-7.4-rename-m4-fix.patch b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
index f869f439c..817720066 100644
--- a/package/coreutils/coreutils-7.4-rename-m4-fix.patch
+++ b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
@@ -23,3 +23,22 @@ Index: coreutils-7.4/m4/rename.m4
AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
[Define if rename does not work when the destination file exists,
as on Windows.])
+Index: coreutils-7.4/configure
+===================================================================
+--- coreutils-7.4.orig/configure
++++ coreutils-7.4/configure
+@@ -28698,12 +28698,12 @@ $as_echo "$gl_cv_func_rename_dest_exists
+
+ $as_echo "#define rename rpl_rename" >>confdefs.h
+
+- if test $gl_cv_func_rename_trailing_slash_bug; then
++ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
+
+ $as_echo "#define RENAME_TRAILING_SLASH_BUG 1" >>confdefs.h
+
+ fi
+- if test $gl_cv_func_rename_dest_exists_bug; then
++ if test $gl_cv_func_rename_dest_exists_bug = yes; then
+
+ $as_echo "#define RENAME_DEST_EXISTS_BUG 1" >>confdefs.h
+
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index d2a3586e4..0dcb62b67 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -23,6 +23,9 @@ $(COREUTILS_DIR)/.unpacked: $(DL_DIR)/$(COREUTILS_SOURCE)
$(COREUTILS_CAT) $(DL_DIR)/$(COREUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(COREUTILS_DIR) package/coreutils/ coreutils\*.patch
$(CONFIG_UPDATE) $(COREUTILS_DIR)/build-aux
+ # ensure rename.m4 file is older than configure / aclocal.m4 so
+ # auto* isn't rerun
+ touch -d '1979-01-01' $(@D)/m4/rename.m4
touch $@
$(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked