summaryrefslogtreecommitdiffstats
path: root/package/coreutils
diff options
context:
space:
mode:
authorPeter Korsgaard <jacmet@sunsite.dk>2009-12-01 10:14:26 +0100
committerPeter Korsgaard <jacmet@sunsite.dk>2009-12-01 10:22:12 +0100
commitc14fb7c1dde86df909e00d2671b2ccf98485cf30 (patch)
treed931214703046e1f67ebfb8c88831061a82ae511 /package/coreutils
parent78f2cb70e2827df9b2b684e54234fc5520003624 (diff)
downloadbuildroot-novena-c14fb7c1dde86df909e00d2671b2ccf98485cf30.tar.gz
buildroot-novena-c14fb7c1dde86df909e00d2671b2ccf98485cf30.zip
package/coreutils: ensure configure isn't considered out-of-date
We were patching m4/rename.m4 to workaround an upstream issue, but this triggers a auto* rebuild and a configure rerun when we build coreutils using whatever auto* versions the user has installed. Doing a manual autoreconf run after patching is unfortunately not an option as the coreutils configure.ac isn't compatible with the autotools version we have in BR. Instead, simply cheat by patching configure as well and setting the timestamp of m4/rename.m4 sufficiently far back to ensure make doesn't consider ./configure out of date. Long term we should convert coreutils to Makefile.autotools.in format, but this is good enought for 2009.11. Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
Diffstat (limited to 'package/coreutils')
-rw-r--r--package/coreutils/coreutils-7.4-rename-m4-fix.patch19
-rw-r--r--package/coreutils/coreutils.mk3
2 files changed, 22 insertions, 0 deletions
diff --git a/package/coreutils/coreutils-7.4-rename-m4-fix.patch b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
index f869f439c..817720066 100644
--- a/package/coreutils/coreutils-7.4-rename-m4-fix.patch
+++ b/package/coreutils/coreutils-7.4-rename-m4-fix.patch
@@ -23,3 +23,22 @@ Index: coreutils-7.4/m4/rename.m4
AC_DEFINE([RENAME_DEST_EXISTS_BUG], [1],
[Define if rename does not work when the destination file exists,
as on Windows.])
+Index: coreutils-7.4/configure
+===================================================================
+--- coreutils-7.4.orig/configure
++++ coreutils-7.4/configure
+@@ -28698,12 +28698,12 @@ $as_echo "$gl_cv_func_rename_dest_exists
+
+ $as_echo "#define rename rpl_rename" >>confdefs.h
+
+- if test $gl_cv_func_rename_trailing_slash_bug; then
++ if test $gl_cv_func_rename_trailing_slash_bug = yes; then
+
+ $as_echo "#define RENAME_TRAILING_SLASH_BUG 1" >>confdefs.h
+
+ fi
+- if test $gl_cv_func_rename_dest_exists_bug; then
++ if test $gl_cv_func_rename_dest_exists_bug = yes; then
+
+ $as_echo "#define RENAME_DEST_EXISTS_BUG 1" >>confdefs.h
+
diff --git a/package/coreutils/coreutils.mk b/package/coreutils/coreutils.mk
index d2a3586e4..0dcb62b67 100644
--- a/package/coreutils/coreutils.mk
+++ b/package/coreutils/coreutils.mk
@@ -23,6 +23,9 @@ $(COREUTILS_DIR)/.unpacked: $(DL_DIR)/$(COREUTILS_SOURCE)
$(COREUTILS_CAT) $(DL_DIR)/$(COREUTILS_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
toolchain/patch-kernel.sh $(COREUTILS_DIR) package/coreutils/ coreutils\*.patch
$(CONFIG_UPDATE) $(COREUTILS_DIR)/build-aux
+ # ensure rename.m4 file is older than configure / aclocal.m4 so
+ # auto* isn't rerun
+ touch -d '1979-01-01' $(@D)/m4/rename.m4
touch $@
$(COREUTILS_DIR)/.configured: $(COREUTILS_DIR)/.unpacked