summaryrefslogtreecommitdiffstats
path: root/package/cmake
diff options
context:
space:
mode:
Diffstat (limited to 'package/cmake')
-rw-r--r--package/cmake/cmake.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/cmake/cmake.mk b/package/cmake/cmake.mk
new file mode 100644
index 000000000..42d4ff5ed
--- /dev/null
+++ b/package/cmake/cmake.mk
@@ -0,0 +1,20 @@
+CMAKE_VERSION=2.8.0
+CMAKE_SOURCE=cmake-$(CMAKE_VERSION).tar.gz
+CMAKE_SITE=http://www.cmake.org/files/v2.8/
+
+define HOST_CMAKE_CONFIGURE_CMDS
+ (cd $(@D); \
+ ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
+ )
+endef
+
+define HOST_CMAKE_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_CMAKE_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+endef
+
+$(eval $(call GENTARGETS,package,cmake))
+$(eval $(call GENTARGETS,package,cmake,host)) \ No newline at end of file