summaryrefslogtreecommitdiffstats
path: root/package/cmake
diff options
context:
space:
mode:
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-03-02 22:31:26 +0100
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>2010-04-09 11:03:55 +0200
commit73b1ab73d7fcbf3c6db46c8e7c6eb612b7a2b27a (patch)
tree8d94907097c20fe5be9bbd64ab500592c08bff25 /package/cmake
parentea448feff70ba79166fc188fd0247b3d7127a6a0 (diff)
downloadbuildroot-novena-73b1ab73d7fcbf3c6db46c8e7c6eb612b7a2b27a.tar.gz
buildroot-novena-73b1ab73d7fcbf3c6db46c8e7c6eb612b7a2b27a.zip
cmake: new package
Only compilation for the host is supported, why explains why we don't have a Config.in and the corresponding BR2_PACKAGE_CMAKE option. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Diffstat (limited to 'package/cmake')
-rw-r--r--package/cmake/cmake.mk20
1 files changed, 20 insertions, 0 deletions
diff --git a/package/cmake/cmake.mk b/package/cmake/cmake.mk
new file mode 100644
index 000000000..42d4ff5ed
--- /dev/null
+++ b/package/cmake/cmake.mk
@@ -0,0 +1,20 @@
+CMAKE_VERSION=2.8.0
+CMAKE_SOURCE=cmake-$(CMAKE_VERSION).tar.gz
+CMAKE_SITE=http://www.cmake.org/files/v2.8/
+
+define HOST_CMAKE_CONFIGURE_CMDS
+ (cd $(@D); \
+ ./bootstrap --prefix=$(HOST_DIR)/usr --parallel=$(BR2_JLEVEL) \
+ )
+endef
+
+define HOST_CMAKE_BUILD_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define HOST_CMAKE_INSTALL_CMDS
+ $(HOST_MAKE_ENV) $(MAKE) -C $(@D) install
+endef
+
+$(eval $(call GENTARGETS,package,cmake))
+$(eval $(call GENTARGETS,package,cmake,host)) \ No newline at end of file